Bug 13601 - Add -fstack-protector-strong and -fstack-clash-protection to compile flags
Add -fstack-protector-strong and -fstack-clash-protection to compile flags
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.9.0rc3
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-03 08:53 UTC by Andreas Schneider
Modified: 2018-09-27 09:13 UTC (History)
5 users (show)

See Also:


Attachments
patch for 4.9 (4.48 KB, patch)
2018-09-04 15:36 UTC, Andreas Schneider
asn: review? (abartlet)
asn: review? (ab)
asn: review? (jra)
asn: review? (slow)
gd: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2018-09-03 08:53:41 UTC
Add -fstack-protector-strong and -fstack-clash-protection to compile flags

https://developers.redhat.com/blog/2018/03/21/compiler-and-linker-flags-gcc/
Comment 1 Andreas Schneider 2018-09-04 15:36:31 UTC
Created attachment 14475 [details]
patch for 4.9
Comment 2 Guenther Deschner 2018-09-25 15:18:54 UTC
Comment on attachment 14475 [details]
patch for 4.9

LGTM (and both are already in master)
Comment 3 Guenther Deschner 2018-09-25 15:19:20 UTC
Karolin, please add to next 4.9.x release.
Comment 4 Andreas Schneider 2018-09-25 15:19:54 UTC
Karolin, please add to the next release. Thanks.
Comment 5 Karolin Seeger 2018-09-26 11:01:12 UTC
Pushed to autobuild-v4-9-test.
Comment 6 Karolin Seeger 2018-09-27 09:13:48 UTC
Pushed to v4-9-test.
Closing out bug report.

Thanks!