Bug 13574 - linking error during samba build on hp-ux 11.31
linking error during samba build on hp-ux 11.31
Status: RESOLVED DUPLICATE of bug 11984
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.8.3
IA64 HP-UX
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-15 06:51 UTC by l.svoboda
Modified: 2019-06-11 21:25 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description l.svoboda 2018-08-15 06:51:01 UTC
Hi, because of missing samba server on hp-ux systems. HPE Samba server product has been ended.
I'm forced to compile samba from scratch on hp-ux 11.31. I'm almost done but I'm facing following issue during linking process(see below)

my configure setup:./configure --without-systemd --without-ad-dc --without-acl-support

OS type:

uxlab:/depot/samba/samba-4.8.3 # gcc -v
Using built-in specs.
Target: ia64-hp-hpux11.31
Configured with: ../gcc/configure
Thread model: posix
gcc version 4.2.3
uxlab:/depot/samba/samba-4.8.3 # uname -a
HP-UX uxlab B.11.31 U ia64 4209004854 unlimited-user license

uxlab:/depot/samba/samba-4.8.3 # machinfo
CPU info:
   Intel(R)  Itanium(R)  Processor 9540 (2.13 GHz, 24 MB)
   8 cores, 16 logical processors per socket
   6.38 GT/s QPI, CPU version D0
          Active processor count:
          1 socket
          1 core
          1 logical processor (1 per socket)
          LCPU attribute is disabled

Memory: 8185 MB (7.99 GB)

Firmware info:
   Firmware revision:  06.30.00.04
   FP SWA driver revision: 1.18
   IPMI is supported on this system.
   BMC firmware revision: 6.1e

Platform info:
   Model:                  "ia64 hp Integrity Virtual Partition"
   Machine ID number:      fae05136-7b69-11e8-b310-3863bb4c62e2
   Machine serial number:  VM01826000

OS info:
   Nodename:  uxlab
   Release:   HP-UX B.11.31
   Version:   U (unlimited-user license)
   Machine:   ia64
   ID Number: 4209004854
   vmunix _release_version:              
@(#) $Revision: vmunix:    B.11.31_LR FLAVOR=perf

[3237/3438] Linking default/source3/utils/samba-regedit
ld: Unsatisfied symbol "field_buffer" in file vi .o
ld: Unsatisfied symbol "set_field_back" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "dynamic_field_info" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "new_field" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "set_current_field" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "move_panel" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "replace_panel" in file default/source3/utils/regedit_treeview_38.o
ld: Unsatisfied symbol "unpost_form" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "set_field_opts" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "free_form" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "pos_form_cursor" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "post_form" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "new_form" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "new_panel" in file default/source3/utils/regedit_treeview_38.o
ld: Unsatisfied symbol "del_panel" in file default/source3/utils/regedit_treeview_38.o
ld: Unsatisfied symbol "free_field" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "form_driver" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "update_panels" in file default/source3/utils/regedit_38.o
ld: (Warning) Unsatisfied symbol "dirfd" in file /depot/samba/samba-4.8.3/bin/default//../default/lib/replace/libreplace-samba4.sl
ld: Unsatisfied symbol "set_form_win" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "set_form_sub" in file default/source3/utils/regedit_dialog_38.o
ld: Unsatisfied symbol "set_field_buffer" in file default/source3/utils/regedit_dialog_38.o
1 warning.
21 errors.
collect2: ld returned 1 exit status
Waf: Leaving directory `/depot/samba/samba-4.8.3/bin'
Build failed:  -> task failed (err #1):
        {task: cc_link regedit_38.o,regedit_samba3_38.o,regedit_wrap_38.o,regedit_treeview_38.o,regedit_valuelist_38.o,regedit_dialog_38.o,regedit_hexedit_38.o,regedit_list_38.o -> samba-regedit}
*** Error exit code 1

Stop.

with following configure setup I'm getting similar issue:

./configure --without-systemd --without-ad-dc --without-acl-support --without-regedit

[3363/3429] Linking default/source4/torture/smbtorture
ld: Unsatisfied symbol "getpwent_r" in file default/source4/torture/local/nss_tests_1.o
ld: Unsatisfied symbol "getgrent_r" in file default/source4/torture/local/nss_tests_1.o
ld: (Warning) Unsatisfied symbol "dirfd" in file /depot/samba/samba-4.8.3/bin/default//../default/lib/replace/libreplace-samba4.sl
1 warning.
2 errors.
collect2: ld returned 1 exit status
Waf: Leaving directory `/depot/samba/samba-4.8.3/bin'
Build failed:  -> task failed (err #1):
        {task: cc_link generic_15.o,hive_15.o,diff_15.o,registry_15.o,rap_10.o,rpc_10.o,printing_10.o,sam_10.o,util_smb_1.o,qfsinfo_4.o,qfileinfo_4.o,setfileinfo_4.o,search_4.o,close_4.o,open_4.o,mkdir_4.o,oplock_4.o,notify_4.o,mux_4.o,ioctl_4.o,chkpath_4.o,unlink_4.o,read_4.o,context_4.o,session_4.o,write_4.o,lock_4.o,pingpong_4.o,lockbench_4.o,lookuprate_4.o,tconrate_4.o,openbench_4.o,rename_4.o,eas_4.o,streams_4.o,acls_4.o,seek_4.o,samba3hide_4.o,samba3misc_4.o,composite_4.o,raw_4.o,offline_4.o,clilsa_2.o,ndr_witness_c_164.o,common_20.o,basic_20.o,schema_20.o,uptodatevector_20.o,cldap_20.o,netlogon_20.o,cldapbench_20.o,ldap_sort_20.o,nested_search_20.o,ndr_browser_c_133.o,ntlmssp_14.o,pac_14.o,smbencrypt_14.o,ndr_rap_45.o,ndr_rap_45.o,smbtorture_30.o,torture_30.o,shell_30.o,drs_init_1.o,drs_util_1.o,prefixmap_tests_1.o,schemainfo_tests_1.o,dssync_1.o,msds_intid_1.o,gpo_1.o,apply_1.o,winbind_1.o,struct_based_1.o,wbclient_1.o,query_22.o,register_22.o,wins_22.o,winsbench_22.o,winsreplication_22.o,dgram_22.o,nbt_22.o,wb_utils_1.o,iconv_1.o,testsuite_1.o,messaging_1.o,irpc_1.o,binding_string_1.o,idtree_1.o,dlinklist_1.o,testsuite_1.o,testsuite_1.o,strlist_1.o,binsearch_1.o,str_1.o,time_1.o,asn1_tests_1.o,data_blob_1.o,file_1.o,genrand_1.o,testsuite_1.o,charset_1.o,convert_string_1.o,sddl_1.o,testsuite_1.o,testsuite_1.o,share_1.o,loadparm_1.o,simple_1.o,local_1.o,dbspeed_1.o,torture_1.o,ldb_1.o,dsdb_dn_1.o,schema_syntax_1.o,anonymous_shared_1.o,strv_1.o,strv_util_1.o,util_1.o,util_str_escape_1.o,tfork_1.o,verif_trailer_1.o,nss_tests_1.o,fsrvp_state_1.o,ndr_unixinfo_c_132.o,nbio_16.o,nbench_16.o,ndr_remact_c_151.o,join_8.o,lsa_8.o,forest_trust_8.o,lsa_lookup_8.o,session_key_8.o,echo_8.o,dfs_8.o,drsuapi_8.o,drsuapi_w2k8_8.o,drsuapi_cracknames_8.o,dsgetinfo_8.o,spoolss_8.o,spoolss_win_8.o,spoolss_access_8.o,unixinfo_8.o,samr_8.o,samr_accessmask_8.o,samr_priv_8.o,wkssvc_8.o,srvsvc_8.o,svcctl_8.o,atsvc_8.o,eventlog_8.o,epmapper_8.o,winreg_8.o,initshutdown_8.o,oxidresolve_8.o,remact_8.o,mgmt_8.o,scanner_8.o,autoidl_8.o,countcalls_8.o,testjoin_8.o,schannel_8.o,netlogon_8.o,remote_pac_8.o,samlogon_8.o,samsync_8.o,dssetup_8.o,alter_context_8.o,bench_8.o,samba3rpc_8.o,rpc_8.o,async_bind_8.o,handles_8.o,frsapi_8.o,object_uuid_8.o,ntsvcs_8.o,browser_8.o,bind_8.o,fsrvp_8.o,clusapi_8.o,witness_8.o,iremotewinspool_8.o,rap_1.o,ndr_dssetup_c_145.o,ntp_signd_26.o,vfs_28.o,fruit_28.o,acl_xattr_28.o,libsmbclient_1.o,base_2.o,misc_2.o,scanner_2.o,utable_2.o,charset_2.o,mangle_test_2.o,denytest_2.o,aliases_2.o,locking_2.o,secleak_2.o,rename_2.o,dir_2.o,delete_2.o,unlink_2.o,disconnect_2.o,delaywrite_2.o,attr_2.o,properties_2.o,ndr_backupkey_c_160.o,ndr_rot_c_118.o,unix_18.o,whoami_18.o,unix_info2_18.o,acls_1.o,compound_1.o,connect_1.o,create_1.o,credits_1.o,delete-on-close_1.o,dir_1.o,dosmode_1.o,durable_open_1.o,durable_v2_open_1.o,getinfo_1.o,ioctl_1.o,lease_1.o,lease_break_handler_1.o,lock_1.o,maxfid_1.o,maxwrite_1.o,notify_1.o,notify_disabled_1.o,oplock_1.o,read_1.o,rename_1.o,replay_1.o,scan_1.o,session_1.o,setinfo_1.o,sharemode_1.o,smb2_1.o,streams_1.o,util_1.o,popt_common_4.o,ndr_fsrvp_state_185.o,libnetapi_1.o,libnetapi_user_1.o,libnetapi_group_1.o,libnetapi_server_1.o,echo_1.o,smbtorture.objlist.empty_32.o,domaindfs_12.o,common_12.o,popt_credentials_5.o,libnet_24.o,utils_24.o,userinfo_24.o,userman_24.o,groupinfo_24.o,groupman_24.o,domain_24.o,libnet_lookup_24.o,libnet_user_24.o,libnet_group_24.o,libnet_share_24.o,libnet_rpc_24.o,libnet_domain_24.o,libnet_BecomeDC_24.o,ndr_fsrvp_c_163.o,srv_fss_state_13.o,testsuite_4.o,strptime_4.o,os2_delete_4.o,getifaddrs_4.o,ndr_6.o,winreg_6.o,atsvc_6.o,lsa_6.o,epmap_6.o,dfs_6.o,netlogon_6.o,drsuapi_6.o,spoolss_6.o,ntprinting_6.o,samr_6.o,dfsblob_6.o,drsblobs_6.o,nbt_6.o,ntlmssp_6.o,string_6.o,backupkey_6.o,witness_6.o,clusapi_6.o,negoex_6.o,krb5pac_6.o,winspool_6.o,cabinet_6.o,charset_6.o,ndr_winspool_c_135.o,echo_1.o,smbreadline_1.o,ndr_oxidresolver_c_150.o,winsrepl_10.o,md4test_2.o,md5test_2.o,hmacmd5test_2.o,aes_cmac_128_test_2.o,aes_ccm_128_test_2.o,aes_gcm_128_test_2.o,ndr_clusapi_c_165.o,ndr_frsapi_c_127.o -> smbtorture}
*** Error exit code 1

Stop.

Thanks a lot for your support.
Comment 1 Amit Kumar 2019-01-08 06:18:28 UTC
Hello,
I believe samba-4.8.3 does not provide "_38" version of headers or .c files.
source3/utils/regedit_dialog_38.o
# ls -ltr source3/utils/regedit_dialog.
regedit_dialog.c  regedit_dialog.h
#

How you have got source code, have you done any modification?
Comment 2 Andrew Bartlett 2019-06-11 20:46:28 UTC
(In reply to Amit Kumar from comment #1)
Armit,

The _38.o is a waf artifact, that much is normal.  

(In reply to l.svoboda from comment #0)

This appears to have been fixed in f460bb52ed4393722d58f9e6d30bd0c7e6a51f1d for bug 11984 in Samba 4.10.

(The regedit thing is also a bug, of underlinking, but given the workaround I won't be looking into it further). 

Can you try the latest version?

*** This bug has been marked as a duplicate of bug 11984 ***