Bug 13542 - Only build dns server and dsdb Python code for AD DC
Only build dns server and dsdb Python code for AD DC
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.9.0rc1
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 11871 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-23 14:20 UTC by Guenther Deschner
Modified: 2018-08-13 10:45 UTC (History)
2 users (show)

See Also:


Attachments
patch for 4.9 (4.85 KB, patch)
2018-07-24 12:02 UTC, Guenther Deschner
no flags Details
patch for 4.9 v2 (4.54 KB, patch)
2018-07-24 13:46 UTC, Guenther Deschner
ab: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guenther Deschner 2018-07-23 14:20:55 UTC

    
Comment 1 Guenther Deschner 2018-07-24 12:02:49 UTC
Created attachment 14332 [details]
patch for 4.9
Comment 2 Alexander Bokovoy 2018-07-24 12:08:23 UTC
The patch for python/samba/tests/__init__.py needs a different fix for 4.9 as there we aren't yet py3-compatible.
Comment 3 Guenther Deschner 2018-07-24 13:46:30 UTC
Created attachment 14333 [details]
patch for 4.9 v2
Comment 4 Alexander Bokovoy 2018-07-24 14:02:27 UTC
Comment on attachment 14333 [details]
patch for 4.9 v2

LGTM. Thanks!
Comment 5 Guenther Deschner 2018-07-24 14:30:17 UTC
Karolin, please add to 4.9, thanks!
Comment 6 Andrew Bartlett 2018-07-27 07:04:00 UTC
*** Bug 11871 has been marked as a duplicate of this bug. ***
Comment 7 Karolin Seeger 2018-07-28 03:47:43 UTC
Pushed to autobuild-v4-9-test.
Comment 8 Karolin Seeger 2018-08-13 10:45:17 UTC
(In reply to Karolin Seeger from comment #7)
Pushed to v4-9-test.
Closing out bug report.

Thanks!