Bug 13515 - smbpasswd and pdbedit crash in a clustered setup
smbpasswd and pdbedit crash in a clustered setup
Status: RESOLVED DUPLICATE of bug 13465
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Clustering
unspecified
All All
: P5 normal
: ---
Assigned To: Ralph Böhme
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-09 14:21 UTC by Ralph Böhme
Modified: 2018-07-10 10:34 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Böhme 2018-07-09 14:21:45 UTC
smbpasswd initializes messaging to late, pdbedit doesn't initialize it at all. This is essentially the same problem as in bug #13465.

smbpasswd SBT:

#0  0x00007ffff4f6b91f in raise () from /lib64/libc.so.6
#1  0x00007ffff4f6d51a in abort () from /lib64/libc.so.6
#2  0x00007ffff7958156 in smb_panic_default (why=0x7ffff2a9b633 "messaging not initialized\n") at ../lib/util/fault.c:160
#3  0x00007ffff7958194 in smb_panic (why=0x7ffff2a9b633 "messaging not initialized\n") at ../lib/util/fault.c:173
#4  0x00007ffff2a92087 in messaging_ctdb_connection () at ../source3/lib/messages_ctdb.c:284
#5  0x00007ffff76e6b88 in db_open (mem_ctx=0x0, name=0x55555578b1e0 "/opt/samba/var/locks/registry.tdb", hash_size=0, tdb_flags=128, open_flags=2, mode=384,
    lock_order=DBWRAP_LOCK_ORDER_1, dbwrap_flags=0) at ../source3/lib/dbwrap/dbwrap_open.c:160
#6  0x00007ffff76c2357 in regdb_init () at ../source3/registry/reg_backend_db.c:744
#7  0x00007ffff76c6cdf in registry_init_common () at ../source3/registry/reg_init_basic.c:33
#8  0x00007ffff7707753 in registry_init_smbconf (keyname=0x7ffff7720e31 "HKLM\\SOFTWARE\\Samba\\smbconf") at ../source3/registry/reg_init_smbconf.c:49
#9  0x00007ffff77060d7 in smbconf_reg_init (ctx=0x55555578af10, path=0x7ffff7720e31 "HKLM\\SOFTWARE\\Samba\\smbconf") at ../source3/lib/smbconf/smbconf_reg.c:606
#10 0x00007ffff7709c93 in smbconf_init_internal (mem_ctx=0x0, conf_ctx=0x7ffff7937098 <conf_ctx>, path=0x0, ops=0x7ffff79364a0 <smbconf_ops_reg>) at ../lib/smbconf/smbconf_util.c:59
#11 0x00007ffff7706e88 in smbconf_init_reg (mem_ctx=0x0, conf_ctx=0x7ffff7937098 <conf_ctx>, path=0x0) at ../source3/lib/smbconf/smbconf_reg.c:1216
#12 0x00007ffff7704e93 in smbconf_init (mem_ctx=0x0, conf_ctx=0x7ffff7937098 <conf_ctx>, source=0x7ffff77102d1 "registry:") at ../source3/lib/smbconf/smbconf_init.c:72
#13 0x00007ffff76d1fe8 in lp_smbconf_ctx () at ../source3/param/loadparm.c:2100
#14 0x00007ffff76d21f3 in process_registry_service (service_name=0x7ffff7710276 "global") at ../source3/param/loadparm.c:2156
#15 0x00007ffff76d23e4 in process_registry_globals () at ../source3/param/loadparm.c:2217
#16 0x00007ffff76d2ab5 in lp_include (lp_ctx=0x55555577ba90, service=0x0, pszParmValue=0x55555578881a "registry", ptr=0x7ffff7936ea8 <sDefault+232>)
    at ../source3/param/loadparm.c:2432
#17 0x00007ffff1820cbb in handle_include (lp_ctx=0x55555577ba90, service=0x0, pszParmValue=0x55555578881a "registry", ptr=0x7ffff7936ea8 <sDefault+232>)
    at ../lib/param/loadparm.c:1165
#18 0x00007ffff18224f6 in set_variable (mem_ctx=0x55555577be70, service=0x0, parmnum=169, parm_ptr=0x7ffff7936ea8 <sDefault+232>, pszParmName=0x555555788810 "include",
    pszParmValue=0x55555578881a "registry", lp_ctx=0x55555577ba90, on_globals=true) at ../lib/param/loadparm.c:1775
#19 0x00007ffff18228aa in lpcfg_do_global_parameter (lp_ctx=0x55555577ba90, pszParmName=0x555555788810 "include", pszParmValue=0x55555578881a "registry")
    at ../lib/param/loadparm.c:1827
#20 0x00007ffff76d38b5 in do_parameter (pszParmName=0x555555788810 "include", pszParmValue=0x55555578881a "registry", userdata=0x55555577ba90) at ../source3/param/loadparm.c:2714
#21 0x00007ffff7968ce7 in parse_param (buf=0x555555788810 "include", allow_empty_value=false, pfunc=0x7ffff76d3823 <do_parameter>, private_data=0x55555577ba90)
    at ../lib/util/tini.c:264
#22 0x00007ffff7968db8 in tini_parse (f=0x5555557882b0, allow_empty_value=false, sfunc=0x7ffff76d3a2d <lp_do_section>, pfunc=0x7ffff76d3823 <do_parameter>,
    private_data=0x55555577ba90) at ../lib/util/tini.c:309
#23 0x00007ffff7960f4d in pm_process (filename=0x555555787850 "/opt/samba/etc/smb.conf", sfunc=0x7ffff76d3a2d <lp_do_section>, pfunc=0x7ffff76d3823 <do_parameter>,
    private_data=0x55555577ba90) at ../lib/util/params.c:99
#24 0x00007ffff76d6e48 in lp_load_ex (pszFname=0x7ffff79ae682 "/opt/samba/etc/smb.conf", global_only=true, save_defaults=false, add_ipc=false, reinit_globals=true,
    allow_include_registry=true, load_all_shares=false) at ../source3/param/loadparm.c:3908
#25 0x00007ffff76d726a in lp_load (pszFname=0x7ffff79ae682 "/opt/samba/etc/smb.conf", global_only=true, save_defaults=false, add_ipc=false, reinit_globals=true)
    at ../source3/param/loadparm.c:4017
#26 0x00007ffff76d72dc in lp_load_global (file_name=0x7ffff79ae682 "/opt/samba/etc/smb.conf") at ../source3/param/loadparm.c:4045
#27 0x000055555555790f in process_options (argc=0, argv=0x7fffffffe480, local_flags=576) at ../source3/utils/smbpasswd.c:199
#28 0x00005555555588cf in main (argc=1, argv=0x7fffffffe478) at ../source3/utils/smbpasswd.c:628

pdbedit SBT:

#0  0x00007ffff5ed791f in raise () from /lib64/libc.so.6
#1  0x00007ffff5ed951a in abort () from /lib64/libc.so.6
#2  0x00007ffff7753156 in smb_panic_default (why=0x7ffff33b7633 "messaging not initialized\n") at ../lib/util/fault.c:160
#3  0x00007ffff7753194 in smb_panic (why=0x7ffff33b7633 "messaging not initialized\n") at ../lib/util/fault.c:173
#4  0x00007ffff33ae087 in messaging_ctdb_connection () at ../source3/lib/messages_ctdb.c:284
#5  0x00007ffff74e1b88 in db_open (mem_ctx=0x0, name=0x55555578d590 "/opt/samba/var/locks/registry.tdb", hash_size=0, tdb_flags=128, open_flags=2, mode=384, lock_order=DBWRAP_LOCK_ORDER_1, dbwrap_flags=0)
    at ../source3/lib/dbwrap/dbwrap_open.c:160
#6  0x00007ffff74bd357 in regdb_init () at ../source3/registry/reg_backend_db.c:744
#7  0x00007ffff74c1cdf in registry_init_common () at ../source3/registry/reg_init_basic.c:33
#8  0x00007ffff7502753 in registry_init_smbconf (keyname=0x7ffff751be31 "HKLM\\SOFTWARE\\Samba\\smbconf") at ../source3/registry/reg_init_smbconf.c:49
#9  0x00007ffff75010d7 in smbconf_reg_init (ctx=0x55555578d2c0, path=0x7ffff751be31 "HKLM\\SOFTWARE\\Samba\\smbconf") at ../source3/lib/smbconf/smbconf_reg.c:606
#10 0x00007ffff7504c93 in smbconf_init_internal (mem_ctx=0x0, conf_ctx=0x7ffff7732098 <conf_ctx>, path=0x0, ops=0x7ffff77314a0 <smbconf_ops_reg>) at ../lib/smbconf/smbconf_util.c:59
#11 0x00007ffff7501e88 in smbconf_init_reg (mem_ctx=0x0, conf_ctx=0x7ffff7732098 <conf_ctx>, path=0x0) at ../source3/lib/smbconf/smbconf_reg.c:1216
#12 0x00007ffff74ffe93 in smbconf_init (mem_ctx=0x0, conf_ctx=0x7ffff7732098 <conf_ctx>, source=0x7ffff750b2d1 "registry:") at ../source3/lib/smbconf/smbconf_init.c:72
#13 0x00007ffff74ccfe8 in lp_smbconf_ctx () at ../source3/param/loadparm.c:2100
#14 0x00007ffff74cd1f3 in process_registry_service (service_name=0x7ffff750b276 "global") at ../source3/param/loadparm.c:2156
#15 0x00007ffff74cd3e4 in process_registry_globals () at ../source3/param/loadparm.c:2217
#16 0x00007ffff74cdab5 in lp_include (lp_ctx=0x55555577f030, service=0x0, pszParmValue=0x55555578bcca "registry", ptr=0x7ffff7731ea8 <sDefault+232>) at ../source3/param/loadparm.c:2432
#17 0x00007ffff5a82cbb in handle_include (lp_ctx=0x55555577f030, service=0x0, pszParmValue=0x55555578bcca "registry", ptr=0x7ffff7731ea8 <sDefault+232>) at ../lib/param/loadparm.c:1165
#18 0x00007ffff5a844f6 in set_variable (mem_ctx=0x55555577f410, service=0x0, parmnum=169, parm_ptr=0x7ffff7731ea8 <sDefault+232>, pszParmName=0x55555578bcc0 "include", pszParmValue=0x55555578bcca "registry", 
    lp_ctx=0x55555577f030, on_globals=true) at ../lib/param/loadparm.c:1775
#19 0x00007ffff5a848aa in lpcfg_do_global_parameter (lp_ctx=0x55555577f030, pszParmName=0x55555578bcc0 "include", pszParmValue=0x55555578bcca "registry") at ../lib/param/loadparm.c:1827
#20 0x00007ffff74ce8b5 in do_parameter (pszParmName=0x55555578bcc0 "include", pszParmValue=0x55555578bcca "registry", userdata=0x55555577f030) at ../source3/param/loadparm.c:2714
#21 0x00007ffff7763ce7 in parse_param (buf=0x55555578bcc0 "include", allow_empty_value=false, pfunc=0x7ffff74ce823 <do_parameter>, private_data=0x55555577f030) at ../lib/util/tini.c:264
#22 0x00007ffff7763db8 in tini_parse (f=0x55555578b760, allow_empty_value=false, sfunc=0x7ffff74cea2d <lp_do_section>, pfunc=0x7ffff74ce823 <do_parameter>, private_data=0x55555577f030) at ../lib/util/tini.c:309
#23 0x00007ffff775bf4d in pm_process (filename=0x55555578ad00 "/opt/samba/etc/smb.conf", sfunc=0x7ffff74cea2d <lp_do_section>, pfunc=0x7ffff74ce823 <do_parameter>, private_data=0x55555577f030)
    at ../lib/util/params.c:99
#24 0x00007ffff74d1e48 in lp_load_ex (pszFname=0x7ffff77a9682 "/opt/samba/etc/smb.conf", global_only=true, save_defaults=false, add_ipc=false, reinit_globals=true, allow_include_registry=true, load_all_shares=false)
    at ../source3/param/loadparm.c:3908
#25 0x00007ffff74d226a in lp_load (pszFname=0x7ffff77a9682 "/opt/samba/etc/smb.conf", global_only=true, save_defaults=false, add_ipc=false, reinit_globals=true) at ../source3/param/loadparm.c:4017
#26 0x00007ffff74d22dc in lp_load_global (file_name=0x7ffff77a9682 "/opt/samba/etc/smb.conf") at ../source3/param/loadparm.c:4045
#27 0x000055555555aabb in main (argc=2, argv=0x7fffffffe468) at ../source3/utils/pdbedit.c:1120

Have fix, need bugnumber
Comment 1 Ralph Böhme 2018-07-10 10:34:33 UTC
Even more client tools have this problem. Closing this PR, using original bug #13465 to track this.

*** This bug has been marked as a duplicate of bug 13465 ***