Bug 1350 - strange directory names with dos client
strange directory names with dos client
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.1
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-14 02:04 UTC by mario
Modified: 2004-07-16 23:49 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mario 2004-05-14 02:04:15 UTC
hi list!

excuse my bad english :-)

after two days of search in the whole internet i cant find an anwser or help to
my question.

i've installed samba 3.0.1 (rpm build) on linux redhat 9.0. since i've done this
i've a strange behavor with my dos client. befor upgrading, under dos the long
directories appears as i want. e.g.:
windows --- yyyyzzzzx
dos --- YYYYZZ~1 or similar.

now with the new samba version i have the following:
windows --- yyyyzzzzx
dos --- YA0E3D~A or similar.

so my question is:

i'm to stupid to make an right configure in the smb.conf?
i've tried everything. such as charakter encodeing, mangeling, protocol.....
or is this an bug and i must upgrade to an newer samba version?

many thanks for all answers!!

greetings from mario - austria
Comment 1 SATOH Fumiyasu 2004-07-12 19:53:19 UTC
This is NOT a bug.
Use the following option in your smb.conf:

[global]
mangling method = hash

Please change the Status of this bug report to ``INVALID''.
Comment 2 mario 2004-07-16 23:49:45 UTC
no bug. false parameters in conf file.
sorry.