Bug 1346 - Winbind crashes at least once per 24h in a ADS setup
Winbind crashes at least once per 24h in a ADS setup
Status: RESOLVED DUPLICATE of bug 1308
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.2a
All Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 05:25 UTC by Daniel Meyer
Modified: 2005-11-14 09:28 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Meyer 2004-05-12 05:25:52 UTC
I'm using samba-3.0.2a-51 (the version shipped with Suse 9.1 professional).

The server is used as a fileserver for a network with a windows 2003 server
using ADS.

Everything works just fine (wbinfo -t, -u, -g, whatever). At least once per day
the connection to the ADS breaks, restarting winbindd solves the problem.

The logfile says:

[2004/05/12 06:49:48, 1] nsswitch/winbindd_ads.c:ads_cached_connection(65)
  ads_connect for domain <DOMAIN> failed: Invalid credentials
[2004/05/12 06:49:48, 1] nsswitch/winbindd_user.c:winbindd_getpwnam(157)
  user '<NAME>' does not exist

And from then it keeps saying:

[2004/05/12 11:39:19, 1] nsswitch/winbindd_util.c:winbindd_lookup_name_by_sid(429)
  Can't find domain from sid


Basic smb.conf (items in <> are changed):
[global]
   workgroup = <NAME>
   netbios name = <SERVERNAME>
   interfaces = 127.0.0.1 eth0
   bind interfaces only = true
   printing = cups
   printcap name = cups
   printer admin = @ntadmin, root, administrator
   map to guest = Bad User
   security = ADS
   realm = <REALM>
   encrypt passwords = yes
   passdb backend = smbpasswd
   server string = Temporaerer Fileserver
   add machine script = 
   domain master = false
   domain logons = no
   local master = no
   preferred master = auto
   ldap suffix = dc=example,dc=com
   password server = <DC>
   winbind cache time = 10
   idmap uid = 10000-20000
   idmap gid = 10000-20000
   winbind uid = 10000-20000
   winbind gid = 10000-20000
   winbind separator = +
   admin users = <WINDOWSADMINNAME>

Followed by normal share definitions.
Comment 1 Gerald (Jerry) Carter 2004-05-12 08:18:51 UTC

*** This bug has been marked as a duplicate of 1308 ***
Comment 2 Gerald (Jerry) Carter 2004-05-12 12:19:30 UTC
shoul have been marked as a duplicate for bug 1208
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:28:26 UTC
database cleanup