Bug 13393 - Samba crashed when kerberos method is set to 'secrets and keytab'
Samba crashed when kerberos method is set to 'secrets and keytab'
Status: RESOLVED DUPLICATE of bug 13376
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.7.1
All All
: P5 normal
: ---
Assigned To: Andreas Schneider
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-18 11:51 UTC by Andreas Schneider
Modified: 2018-04-18 12:56 UTC (History)
1 user (show)

See Also:


Attachments
patch for master (1.00 KB, patch)
2018-04-18 11:51 UTC, Andreas Schneider
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2018-04-18 11:51:01 UTC
Samba crashed when 'kerberos method' is set to 'secrets and keytab'.

#8  fill_mem_keytab_from_secrets (krbctx=0x55def3fe34f0, keytab=0x55def3fe3440) at ../source3/librpc/crypto/gse_krb5.c:186
        frame = 0x55def3fe55d0
        ret = <optimized out>
        domain = 0x55def3fb4740 "PROD"
        info = 0x0
        realm = 0x0
        ct = 0x0
        kt_cursor = 0x7fc002524e9d <k5_os_mutex_unlock+29>
        kt_entry = {magic = -201435968, principal = 0x7fc007ceb250 <krb5_mkt_resolve+192>, timestamp = -201444112, vno = 21982, key = {magic = 0, enctype = 0, length = 133757856, contents = 0x55def3fe54a0 "\354\001"}}
        princ = 0x0
        status = <optimized out>
        __FUNCTION__ = "fill_mem_keytab_from_secrets"
        __func__ = "fill_mem_keytab_from_secrets"

We derefrence info which is a NULL pointer. It is NULL because secrets_fetch_or_upgrade_domain_info() returned NT_STATUS_OK without filling pinfo.
Comment 1 Andreas Schneider 2018-04-18 11:51:42 UTC
Created attachment 14154 [details]
patch for master
Comment 2 Andreas Schneider 2018-04-18 11:52:46 UTC
This happens when sssd is used instead of winbind.
Comment 3 Stefan Metzmacher 2018-04-18 12:56:07 UTC

*** This bug has been marked as a duplicate of bug 13376 ***