Bug 13333 - samba fails to build
samba fails to build
Status: RESOLVED DUPLICATE of bug 13273
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.7.6
All Linux
: P5 major
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-15 10:19 UTC by bugs
Modified: 2018-03-22 09:25 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugs 2018-03-15 10:19:19 UTC
samba, since 4.6.12 fails to compile on slackware with this following configuration, which we have used to build samba for many many years

All 4.7 versions, including the just released 4.7.6 fail.

Notes: 
configure reports completed successfully 
build deliberately excludes ADS/LDAP
Slackware does not come with nor use PAM or Kerberos 
   (none of which have ever been needed before to build samba)

./configure --enable-fhs --prefix=/usr --libdir=/usr/lib$ --includedir=/usr/include --bindir=/usr/bin --sbindir=/usr/sbin --mandir=/usr/man --sysconfdir=/etc --with-configdir=/etc/samba --with-piddir=/var/run --with-privatedir=/var/lib/samba/private --with-privatelibdir=/usr/lib --with-modulesdir=/usr/lib  --with-lockdir=/var/cache/samba --with-logfilebase=/var/log/samba --localstatedir=/var --enable-cups --with-acl-support --with-automount --with-quotas --with-syslog --with-utmp --with-winbind --without-ldap --without-ads --without-pam  --build=i586-slackware-linux



3592/3915] Linking default/source3/smbspool
[3593/3915] Linking default/examples/fuse/smb2mount
[3594/3915] Linking default/source4/lib/registry/regdiff
[3595/3915] Linking default/source3/libsmb/libsmbclient.so
[3596/3915] Linking default/source4/ntvfs/posix/python-xattr-tdb.so
[3597/3915] Linking default/source4/librpc/python-dcerpc-nbt.so
[3598/3915] Linking default/source4/dsdb/samdb/ldb_modules/libldb_module_dirsync.so
[3599/3915] Linking default/source4/dsdb/samdb/ldb_modules/libldb_module_repl_meta_data.so
[3600/3915] Linking default/source4/dsdb/samdb/ldb_modules/libldb_module_objectclass_attrs.so
[3601/3915] Linking default/source3/utils/smbcontrol
[3602/3915] Linking default/source3/locktest2
[3603/3915] Linking default/source4/librpc/python-dcerpc-xattr.so
[3604/3915] Linking default/source3/utils/pdbedit
[3605/3915] Linking default/source4/librpc/python-dcerpc-idmap.so
[3606/3915] Linking default/source3/libtrusts-util-samba4.so
[3607/3915] Linking default/source3/libads-samba4.so
default/source3/libads/kerberos_keytab_63.o: In function `ads_keytab_list':
kerberos_keytab.c:(.text+0x113): undefined reference to `ads_keytab_open'
collect2: error: ld returned 1 exit status
Waf: Leaving directory `/tmp/samba-4.7.6/bin'
Build failed:  -> task failed (err #1): 
        {task: cc_link ldap_63.o,sasl_63.o,sasl_wrapping_63.o,krb5_setpw_63.o,kerberos_util_63.o,ldap_user_63.o,ads_struct_63.o,kerberos_keytab_63.o,disp_sec_63.o,ldap_utils_63.o,ldap_schema_63.o,util_63.o,ndr_63.o,namequery_dc_104.o,trustdom_cache_104.o,dsgetdcname_104.o -> libads-samba4.so}
make: *** [all] Error 1
Comment 1 bugs 2018-03-15 11:05:46 UTC
Tried  our other server, slightly different conf lines and still fails

 LDFLAGS="-Wl,--no-as-needed" CFLAGS="-O2 -fPIC" ./configure --enable-fhs --prefix=/usr --libdir=/usr/lib64 --includedir=/usr/include --bindir=/usr/bin --sbindir=/usr/sbin --mandir=/usr/man --sysconfdir=/etc --with-configdir=/etc/samba --with-piddir=/var/run --with-privatedir=/var/lib/samba/private --with-privatelibdir=/usr/lib64 --with-modulesdir=/usr/lib64 --with-lockdir=/var/cache/samba --with-logfilebase=/var/log/samba --localstatedir=/var --enable-cups --with-acl-support --with-automount --with-quotas --with-syslog --with-utmp --with-winbind --without-ldap --without-ads --without-pam --build=x86_64-slackware-linux



[3657/3915] Linking default/source3/utils/smbget
[3658/3915] Linking default/source4/smbd/libservice-samba4.so
[3659/3915] Linking default/examples/libsmbclient/testctx
[3660/3915] Linking default/source3/libads-samba4.so
default/source3/libads/kerberos_keytab_63.o: In function `ads_keytab_list':
kerberos_keytab.c:(.text+0x144): undefined reference to `ads_keytab_open'
collect2: error: ld returned 1 exit status
Waf: Leaving directory `/tmp/samba-4.7.6/bin'
Build failed:  -> task failed (err #1): 
        {task: cc_link ldap_63.o,sasl_63.o,sasl_wrapping_63.o,krb5_setpw_63.o,kerberos_util_63.o,ldap_user_63.o,ads_struct_63.o,kerberos_keytab_63.o,disp_sec_63.o,ldap_utils_63.o,ldap_schema_63.o,util_63.o,ndr_63.o,namequery_dc_104.o,trustdom_cache_104.o,dsgetdcname_104.o -> libads-samba4.so}



ADS has been specifically disabled, why since 4.6.12 onwards is it ignoring the without-ads  instruction?
Comment 2 Stefan Metzmacher 2018-03-22 09:25:16 UTC

*** This bug has been marked as a duplicate of bug 13273 ***