Bug 13328 - Windows 10 cannot logon on Samba NT4 domain
Windows 10 cannot logon on Samba NT4 domain
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.7.6
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-13 15:41 UTC by Björn Jacke
Modified: 2018-07-01 18:55 UTC (History)
4 users (show)

See Also:


Attachments
network capture between win10 1709 client failing logon against samba NT4 PDC (2.42 KB, application/gzip)
2018-03-13 15:41 UTC, Björn Jacke
no flags Details
Patches for v4-8-test (77.20 KB, patch)
2018-03-16 09:16 UTC, Stefan Metzmacher
slow: review+
Details
Patches for v4-7-test (77.20 KB, patch)
2018-03-16 09:18 UTC, Stefan Metzmacher
slow: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2018-03-13 15:41:31 UTC
Created attachment 14046 [details]
network capture between win10 1709 client failing logon against samba NT4 PDC

When recent Windows 10 clients try to authenticate against a classic Samba NT4 domain this fails unless the server has server max protocol = nt1 set. The reason is a false set guest session flag in the reply of the session setup from the Samba server. Network capture showing the error attached.
Comment 1 Stefan Metzmacher 2018-03-16 09:16:43 UTC
Created attachment 14052 [details]
Patches for v4-8-test
Comment 2 Stefan Metzmacher 2018-03-16 09:18:00 UTC
Created attachment 14053 [details]
Patches for v4-7-test
Comment 3 Ralph Böhme 2018-03-20 13:23:18 UTC
Reassigning to Karolin for inclusion in 4.8 and 4.7.
Comment 4 Stefan Metzmacher 2018-03-20 16:13:25 UTC
Pushed to autobuild-v4-{7,8}-test.
Comment 5 Stefan Metzmacher 2018-03-21 05:59:08 UTC
(In reply to Stefan Metzmacher from comment #4)

Pushed to v4-{7,8}-test
Comment 6 Peter 2018-05-15 06:59:16 UTC
Does this change also address all of the issues in bug 12136, which are related to a Samba share (not a AD DC)?
Comment 7 Björn Jacke 2018-05-15 07:21:29 UTC
this fix addresses this issue and the reporter of that other bug confirmed that it also fixes his issue. Do not ask here if some other bugs are fixed. This issue is closed. Nothing more and nothing less.

If you run into a problem, you should 1) try the latest Samba release and if the latest release has a bug, then you please file a new bug report for that.
Comment 8 Mathieu Parent 2018-06-18 20:23:55 UTC
Those fixes may have introduced a regression:

https://bugs.debian.org/899269
Comment 9 Björn Jacke 2018-06-19 07:01:06 UTC
very unlikely. looks like your bug reporter did not increase the log level to try to find his problem. and he writes he uses sssd.
bugzilla cannot support people. the samba wiki, the mailing list or https://www​.samba.org/samba/support are made for those cases.

On June 18, 2018 10:23:55 PM GMT+02:00, samba-bugs@samba.org wrote:
>https://bugzilla.samba.org/show_bug.cgi?id=13328
>
>--- Comment #8 from Mathieu Parent <sathieu@debian.org> ---
>Those fixes may have introduced a regression:
>
>https://bugs.debian.org/899269
Comment 10 Mathieu Parent 2018-07-01 13:45:08 UTC
Maybe #13486 is a regression (reported also in Debian: https://bugs.debian.org/902431)?