Bug 1328 - Can't distinguish filenames with space at the end in dir listing.
Can't distinguish filenames with space at the end in dir listing.
Status: RESOLVED DUPLICATE of bug 2769
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.2a
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-07 14:50 UTC by Konstantin Starodubtsev
Modified: 2005-09-29 07:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Starodubtsev 2004-05-07 14:50:55 UTC
smbclient currently uses spaces in directory listing as separators for field 
justification and so there's no way to distinguish "separator" spaces 
and "filename" spaces. In the example below "Ainsi Soit Je " directory is 
actually with one space at the end of dirname. It would be useful if field 
separator character could be specified by some commandline option or just 
replaced to tab.

$ smbclient //t/music -Uguest% -D "Mylene Farmer" -c ls
Domain=[DEBIAN_FANS] OS=[Unix] Server=[Samba 3.0.2a-Debian]
  .                                   D        0  Fri Jul 11 02:54:34 2003
  ..                                  D        0  Mon Mar  8 18:02:28 2004
  Ainsi Soit Je                       D        0  Fri Jul 11 02:54:46 2003

                61430 blocks of size 524288. 1927 blocks available
Comment 1 Gerald (Jerry) Carter 2005-09-29 07:40:04 UTC

*** This bug has been marked as a duplicate of 2769 ***