Bug 1320 - Modifying accounts in User Manager disables account!
Modifying accounts in User Manager disables account!
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: User/Group Accounts
3.0.3
Other Windows 2000
: P3 major
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-04 18:33 UTC by Brandon Turner
Modified: 2005-08-24 10:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brandon Turner 2004-05-04 18:33:23 UTC
If an administrator users Microsoft User Manager to modify a user account, the 
account becomes disabled.  I have noticed that Samba 3.0.3 
adds "sambaKickoffTime: 0" to the LDAP account for the user.  If you give the 
account a expiration date in the Account Information section of User Manager 
instead of 'Never' the account is ok.  It seems when trying to make the account 
never expire, Samba 3.0.3 puts 0 for the sambaKickoffTime attribute instead of 
2147483647.  Previous versions did not modify/add this attribute.
Comment 1 Gerald (Jerry) Carter 2005-02-11 07:44:11 UTC
please retest against 3.0.11  I can't reproduce this locally 
using the current code.  Thanks.
Comment 2 Gerald (Jerry) Carter 2005-08-24 10:16:00 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.