Bug 13183 - Samba 4.7.3 compile error
Summary: Samba 4.7.3 compile error
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build (show other bugs)
Version: unspecified
Hardware: All All
: P5 normal (vote)
Target Milestone: 4.7
Assignee: Samba QA Contact
QA Contact: Samba QA Contact
Depends on:
Reported: 2017-12-12 06:05 UTC by Mr Dini
Modified: 2022-02-11 07:40 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Mr Dini 2017-12-12 06:05:17 UTC

I tried to compile the latest stable samba version (4.7.3) on my ARMv5 NAS. The configure script worked well, but the make exited with an error.

Here is the error itself:

../source3/lib/sysquotas_linux.c: In function 'sys_get_vfs_quota':
../source3/lib/sysquotas_linux.c:115:29: error: 'struct dqblk' has no member named 'dqb_curspace'
  dp->curblocks = (uint64_t)D.dqb_curspace/bsize;
../source3/lib/sysquotas_linux.c: In function 'sys_set_vfs_quota':
../source3/lib/sysquotas_linux.c:151:3: error: 'struct dqblk' has no member named 'dqb_valid'
  D.dqb_valid = QIF_LIMITS;
../source3/lib/sysquotas_linux.c:151:16: error: 'QIF_LIMITS' undeclared (first use in this function)
  D.dqb_valid = QIF_LIMITS;
../source3/lib/sysquotas_linux.c:151:16: note: each undeclared identifier is reported only once for each function it appears in
Comment 1 Björn Jacke 2022-02-11 07:40:17 UTC
looks like you have broken a Linux header file there. You might alternatively compile without quota if you can't fix the quota header file