Bug 13081 - smb.conf has parameter descriptions in non-alphabetical order
smb.conf has parameter descriptions in non-alphabetical order
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Documentation
4.7.0
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba Documentation QA Contact~
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-12 07:25 UTC by Alexander Bokovoy
Modified: 2017-11-01 08:58 UTC (History)
2 users (show)

See Also:


Attachments
propsed patch forv v4.7 (2.02 KB, patch)
2017-10-16 14:11 UTC, Alexander Bokovoy
asn: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bokovoy 2017-10-12 07:25:24 UTC
Content of each separate parameter description file is added into a parameters.all.xml file before compiling smb.conf.5.

The issue is that POSIX file systems generally don't give any promises over how glob-produced files are sorted. Thus, we need to sort them in a predictable way.
Comment 1 Alexander Bokovoy 2017-10-16 14:11:42 UTC
Created attachment 13695 [details]
propsed patch forv  v4.7

Cherry-picked from the git master
Comment 2 Andreas Schneider 2017-10-18 07:20:05 UTC
Karolin, please add to the next 4.7 release. Thanks!
Comment 3 Karolin Seeger 2017-10-24 10:59:22 UTC
(In reply to Andreas Schneider from comment #2)
Pushed to autobuild-v4-7-test.
Comment 4 Karolin Seeger 2017-11-01 08:58:05 UTC
(In reply to Karolin Seeger from comment #3)
Pushed to v4-7-test.
Closing out bug report.

Thanks!