Bug 13034 - ldbmodify should support LDIF scripts
ldbmodify should support LDIF scripts
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.6.7
All All
: P5 enhancement
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-14 11:42 UTC by Björn Jacke
Modified: 2017-09-14 19:00 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2017-09-14 11:42:34 UTC
To allow standardized 3rd party schema extensions for Active Directory to be imporable to Samba AD ldbmodify should support LDIF scripts.

Specificylly this includes the following change operations

ntdsSchemaAdd
ntdsSchemaModify
ntdsSchemaDelete
ntdsSchemaModRdn
schemaUpdateNow

as described in https://msdn.microsoft.com/en-us/library/ms677268(v=vs.85).aspx