Bug 13028 - Compression support is broken again
Compression support is broken again
Status: RESOLVED DUPLICATE of bug 12144
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.6.7
All All
: P5 normal
: ---
Assigned To: David Disseldorp
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-09-12 07:55 UTC by Hodur
Modified: 2017-09-12 15:43 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hodur 2017-09-12 07:55:43 UTC
In Windows 2012R2, Hyper-V virtual machine export does not work with samba 4.6 share.

Steps to reproduce

1. In Hyper-V, select export VM, select samba share as destination storage
2. Export failed.

Seems regression bug, VM export works with samba 4.5

./source3/smbd/smb2_ioctl_filesys.c

        if ((fsp->conn->fs_capabilities & FILE_FILE_COMPRESSION) == 0) {
                DEBUG(4, ("FS does not advertise compression support\n"));
                return NT_STATUS_INVALID_DEVICE_REQUEST;
        }
Comment 1 David Disseldorp 2017-09-12 15:43:27 UTC
Sorry for the headache - tracking the 4.6 omission via the original bug...

*** This bug has been marked as a duplicate of bug 12144 ***