Bug 12990 - cli_setpathinfo_basic() doesn't work correctly using SMB2+
cli_setpathinfo_basic() doesn't work correctly using SMB2+
Status: RESOLVED DUPLICATE of bug 12913
Product: Samba 4.1 and newer
Classification: Unclassified
Component: libsmbclient
4.6.7
All All
: P5 regression
: 4.7
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-27 09:06 UTC by Paul Smedley
Modified: 2017-08-28 09:25 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Smedley 2017-08-27 09:06:18 UTC
The OS/2 Samba client uses cli_setpathinfo_basic() to set the file times/dates to their original values before closing a file.

Over SMB1, this works correctly, for SMB2+, an invalid parameter error is returned.

Is it possible that the SMB2+ codepath hasn't been implemented for this function, or do I need to use a different function than cli_setpathinfo_basic() for the SMB2+ case?
Comment 1 Stefan Metzmacher 2017-08-27 12:21:29 UTC
We should check is this is still a problem before 4.7.0.
Comment 2 Stefan Metzmacher 2017-08-27 15:52:40 UTC

*** This bug has been marked as a duplicate of bug 12913 ***
Comment 3 Paul Smedley 2017-08-28 09:25:13 UTC
Confirming the fixes in 12913 fix this issue