Bug 12989 - LDB ldif printing during replication can include confidential data
LDB ldif printing during replication can include confidential data
Status: RESOLVED DUPLICATE of bug 13017
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.7.0rc4
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-26 20:08 UTC by Andrew Bartlett
Modified: 2018-03-29 01:34 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Bartlett 2017-08-26 20:08:19 UTC
We should ensure that when printing the replication traffic, that we redact the secret attributes.

The NDR dump output is safer, as these are encrypted, but the ldif is clear text.
Comment 1 Andrew Bartlett 2018-03-29 01:34:41 UTC
Fixed in master with dc48fa982251292a0d46d701c6e912620caf7c72 and in Samba 4.7 with 66de4c1947aa2f4a20c02c65a4b9d0635f947467.

*** This bug has been marked as a duplicate of bug 13017 ***