Bug 1294 - NT_STATUS_NO_LOGON_SERVERS error after 18 minutes
NT_STATUS_NO_LOGON_SERVERS error after 18 minutes
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.2a
All Solaris
: P2 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on: 870
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-26 02:35 UTC by Juergen Lepper
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Attachments
trace log 2 (15.50 KB, application/octet-stream)
2004-04-26 02:35 UTC, Juergen Lepper
no flags Details
trace log 10 ( compressed tar ) of log.nmbd log.smbd log.winbind (888.64 KB, application/octet-stream)
2004-04-26 02:42 UTC, Juergen Lepper
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Lepper 2004-04-26 02:35:24 UTC
Hallo,
I have a NT_STATUS_NO_LOGON_SERVERS problem, after i have updated my samba
server from version 2.0.7 to samba
3.0.2a. 
Logon works fine for about 18 minutes, then suddenly the communication between
the SAMBA process and the
WINNT PDC does not work anymore.

I have checked my configuration as good as i can. 
e.g. dns resolution, local master browser, smb signing settings,schannel
settings, guest account, remote browse
sync, socket options, packet filtering, wins registration
I dont'find any problem.

I found two bugs on bugzilla, which seemed to me, as if they have nearly the
same problem:
Bug 870 "smbd spuriosly reports NT_STATUS_NO_LOGON_SERVERS" 
and
Bug 331 "User authentification fails NT_STATUS_NO_LOGON_SERVERS ... "

I have an interesting Workarround:
When i use the command "net rpc join -S alien -U'Administrator%********' -W
EPIDAUROS" it works again and the
problem is away for about 18 Minutes. The same workaround was reportet in Bug 870.
So i do this in a cronjob every 5 Minutes, on my production server.
I have a Test Server where the same problem exist.

What i do:
samba 3.0.2a on solaris 8 ( Servername DATENNETZ, 192.168.1.1  )
SunOS e450 5.8 Generic_117000-01 sun4u sparc SUNW,Ultra-4
Windows DOMAIN "EPIDAUROS"
winnt  is a PDC and WINS Server ( Servername ALIEN , 10.1.161.1 )
The servers are in different subnets.
On the solaris machine i only start nmbd and smbd.
( as i understand, i do not need a winbind process, because i have a remote WINS
Server )
I have only 30 Users. On the testserver, i am the single user.
The user accounts exist on the WINNT PDC whith password "A".
On the solaris machine the User has a NIS account, whith the same login name,
but a password "B".
This concept has been implemented before i was in the company, it has worked
whith samba 2.0.7.
Could this be a problem whith samba 3.x?

My smb.conf file is:
   [global]
           workgroup = EPIDAUROS
           netbios name = DATENNETZ
           server string = TESTSERVER mit Samba 3.0.2a
           security = DOMAIN
           password server = ALIEN
           client plaintext auth = No
           log level = 10
           name resolve order = wins host bcast
           socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY
           preferred master = Yes
           domain master = No
           wins server = 10.1.161.1
           ldap ssl = no
           remote announce = 10.1.191.255
   [playground]
           comment = TEST Server, do not use
           path = /daten/playground
           read only = No
           force directory mode = 0770

I have generated the Tracefile whith trace log 2 and 10:
You see the following:
1) server start
2) "smbclient -L datennetz -UEPIDAUROS/juergen0"
added interface ip=192.168.1.34 bcast=192.168.1.255 nmask=255.255.255.0
Password:
session setup failed: NT_STATUS_NO_LOGON_SERVERS
3) "net rpc join -S alien -U'Administrator%********' -W EPIDAUROS"
Joined domain EPIDAUROS.
4) "smbclient -L datennetz -UEPIDAUROS/juergen0"
added interface ip=192.168.1.34 bcast=192.168.1.255 nmask=255.255.255.0
Password:
Domain=[EPIDAUROS] OS=[Unix] Server=[Samba 3.0.2a]

        Sharename      Type      Comment
        ---------      ----      -------
        playground     Disk      TEST Server, do not use
        IPC$           IPC       IPC Service (TESTSERVER mit Samba 3.0.2a)
        ADMIN$         IPC       IPC Service (TESTSERVER mit Samba 3.0.2a)

        Server               Comment
        ---------            -------
        DATENNETZ            TESTSERVER mit Samba 3.0.2a

        Workgroup            Master
        ---------            -------
        EPIDAUROS

This work now, for about 18 Minutes
5) i do a monitoring of samba using netsaint, which tests every 2 minutes using
smbclient
6) suddenly the error is reportet
7) "smbclient -L datennetz -UEPIDAUROS/juergen0"
added interface ip=192.168.1.34 bcast=192.168.1.255 nmask=255.255.255.0
Password:
session setup failed: NT_STATUS_NO_LOGON_SERVERS
8) stoping the server

Regards
Juergen Lepper
Comment 1 Juergen Lepper 2004-04-26 02:35:43 UTC
Created attachment 475 [details]
trace log 2
Comment 2 Juergen Lepper 2004-04-26 02:42:08 UTC
Created attachment 476 [details]
trace log 10 ( compressed tar ) of log.nmbd log.smbd log.winbind
Comment 3 Gerald (Jerry) Carter 2004-05-14 06:44:39 UTC
What OS is ALIEN ?  Any idea why it is not responding to a 
node status request on 137/udp ?


  internal_resolve_name: looking up ALIEN#20
  name ALIEN#20 found.
  remove_duplicate_addrs2: looking for duplicate address/port pairs
  get_dc_list: returning 1 ip addresses in an ordered list
  get_dc_list: 10.1.161.1:0
  name_status_find: looking up EPIDAUROS#1c at 10.1.161.1
  Cache entry with key = NBT/EPIDAUROS#1C.20.10.1.161.1 couldn't be found
  namecache_status_fetch: no entry for NBT/EPIDAUROS#1C.20.10.1.161.1 found.
  Deleting cache entry (key = NBT/EPIDAUROS#1C.20.10.1.161.1)
  bind succeeded on port 0
  Sending a packet of len 50 to (10.1.161.1) on port 137
  Sending a packet of len 50 to (10.1.161.1) on port 137
  name_status_find: name not found
  check_ntdomain_security: unable to locate a DC for domain EPIDAUROS
Comment 4 Juergen Lepper 2004-05-18 03:13:52 UTC
Thank's for your hint!

The problem was caused by the PDC ( Servername ALIEN, WINNT 4.0 whith SP6 +
hotfixes).
As i checked netstat on the WINNT Server, i found different Problems on this
server. netstat didn't work. 

The follwoing error where shown:
 1)
 The interfaceinitialization had an error: 2 
 2) 
 PopUp Windows whith snmpapi.dll Error

I had to reinstall SP6 on this server to solve the above errors.
Now netstat workes fine and shows 137/udp listening.
Samba 3.x on solaris works fine too.

I suppose, that the installation of several hotfixes from Microsoft, had caused
the problem on the winnt box. A fellow has installed these hotfixes on the same
date i was updating samba on my solaris server.

Sorry, for taking your time.
Regards 
Juergen
 
Comment 5 Gerald (Jerry) Carter 2004-05-18 04:52:45 UTC
Windows NT 4.0 DC issue.  Closing as 'not our bug'
Comment 6 Gerald (Jerry) Carter 2005-11-14 09:27:51 UTC
database cleanup