Bug 12905 - enable more python 3 modules
enable more python 3 modules
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Python
4.7.0rc1
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-14 04:41 UTC by Alexander Bokovoy
Modified: 2017-07-25 09:35 UTC (History)
3 users (show)

See Also:


Attachments
patch for 4.7 (10.82 KB, patch)
2017-07-14 09:42 UTC, Alexander Bokovoy
asn: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bokovoy 2017-07-14 04:41:56 UTC
Attached patches fix samba.net.finddc() definition in lieu of
https://bugs.python.org/issue15657 and enable remaining samba.dcerpc
modules to be compiled for Python 3. These two patches are needed to get
FreeIPA moved to Python 3.
Comment 1 Alexander Bokovoy 2017-07-14 09:42:46 UTC
Created attachment 13382 [details]
patch for 4.7

Patch for 4.7 attached
Comment 2 Alexander Bokovoy 2017-07-14 09:43:22 UTC
Comment on attachment 13382 [details]
patch for 4.7

Andreas, please review.
Comment 3 Andreas Schneider 2017-07-14 12:04:24 UTC
Comment on attachment 13382 [details]
patch for 4.7

LGTM
Comment 4 Andreas Schneider 2017-07-14 12:05:06 UTC
Karolin, please add the patchset to the next 4.7 release candidate. Thanks!
Comment 5 Karolin Seeger 2017-07-23 20:16:27 UTC
(In reply to Andreas Schneider from comment #4)
Pushed to autobuild-v4-7-test.
Comment 6 Karolin Seeger 2017-07-25 09:35:12 UTC
(In reply to Karolin Seeger from comment #5)
Pushed to v4-7-test.
Closing out bug report.

Thanks!