Bug 12866 - NETLOGON multi-process appears to currently be falling back to single-process
NETLOGON multi-process appears to currently be falling back to single-process
Status: RESOLVED DUPLICATE of bug 12939
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DCE-RPCs and pipes
unspecified
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 01:57 UTC by Garming Sam
Modified: 2017-07-31 03:19 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Garming Sam 2017-06-27 01:57:38 UTC
At least in some configurations, I see NETLOGON requests from multiple clients being served from the same PID and process.
Comment 1 Stefan Metzmacher 2017-06-27 08:18:01 UTC
4.5.0 doesn't have the multiprocess netlogon patches or am I missing something?
Comment 2 Andrew Bartlett 2017-06-27 08:34:22 UTC
This was noticed in master for 4.7, they were introduced with 4.6.

The mechanism is clearly a little too subtle, we probably need to make it fail if 'uses handles' and 'does not use handles' is combined on the same NP or TCP/IP endpoint.
Comment 3 Garming Sam 2017-07-31 03:19:21 UTC

*** This bug has been marked as a duplicate of bug 12939 ***