Bug 12854 - manpage/index.html lists links not in alphabetical order
manpage/index.html lists links not in alphabetical order
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Documentation
unspecified
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba Documentation QA Contact~
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-21 08:21 UTC by Michio MATSUYAMA
Modified: 2017-06-29 07:40 UTC (History)
2 users (show)

See Also:


Attachments
patch for 4.6 cherry-picked from master (1.37 KB, patch)
2017-06-27 19:10 UTC, Andrew Bartlett
ddiss: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michio MATSUYAMA 2017-06-21 08:21:42 UTC
When we build the HTML manpages by executing 'make htmlman' in the docs-xml directory,  we get output/htmldocs/manpage/index.html file, that have the list of hyperlinks that link to individual HTML manpages.

The problem is that this list is ordered in random, it means not in alphabetical order.

To solve this problem, it sould be modified the 'Makefile' like as follows: ('sort' statement should be added)

--- Makefile.orig       2017-01-11 16:55:14.000000000 +0900
+++ Makefile    2017-06-20 20:29:21.123498429 +0900
@@ -8,7 +8,7 @@

 # Docs to build
 MAIN_DOCS = $(patsubst %/index.xml,%,$(wildcard */index.xml))
-MANPAGES = $(wildcard $(MANPAGEDIR)/*.?.xml)
+MANPAGES = $(sort $(wildcard $(MANPAGEDIR)/*.?.xml))

 # Lists of files to process
 MANPAGES_PLUCKER = $(patsubst $(MANPAGEDIR)/%.xml,$(PLUCKERDIR)/%.pdb,$(MANPAGES))
Comment 1 Andrew Bartlett 2017-06-27 19:10:41 UTC
Created attachment 13317 [details]
patch for 4.6 cherry-picked from master

Fixed by eedebe2ef1b6ff92975289b6076f236650744621 in master for Samba 4.7.

This was also noticed by Bernhard M. Wiedemann for the reproducible builds effort.

Thanks!
Comment 2 Karolin Seeger 2017-06-28 09:14:39 UTC
Pushed to autobuild-v4-6-test.
Comment 3 Karolin Seeger 2017-06-29 07:40:21 UTC
(In reply to Karolin Seeger from comment #2)
Pushed to v4-6-test.
Closing out bug report.

Thanks!