Bug 12812 - Solaris and MSG_NOSIGNAL
Solaris and MSG_NOSIGNAL
Status: RESOLVED DUPLICATE of bug 12502
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
4.6.4
Sparc Solaris
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-31 17:57 UTC by Albert Chin
Modified: 2017-06-12 12:32 UTC (History)
0 users

See Also:


Attachments
Use MSG_NOSIGNAL only if available (565 bytes, patch)
2017-05-31 17:57 UTC, Albert Chin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Chin 2017-05-31 17:57:58 UTC
Created attachment 13244 [details]
Use MSG_NOSIGNAL only if available

Samba-4.6.4 fails to build on Solaris because MSG_NOSIGNAL is not available. This is used in source3/lib/messages_dgm.c. According to send(3) on Solaris, only MSG_OOB and MSG_DONTROUTE are flags to sendmsg().
        ...
        {
                uint8_t buf[fdlen];

                msghdr_prep_fds(&msg, buf, fdlen, fds, num_fds);

                do {
                        ret = sendmsg(sock, &msg, MSG_NOSIGNAL);
                } while ((ret == -1) && (errno == EINTR));
        }
Comment 1 Björn Jacke 2017-06-12 12:32:10 UTC

*** This bug has been marked as a duplicate of bug 12502 ***