Bug 127 - Cannot execute a Windows Program from a Samba Share
Cannot execute a Windows Program from a Samba Share
Status: RESOLVED WONTFIX
Product: Samba 2.2
Classification: Unclassified
Component: File Services
2.2.7a
All Windows XP
: P2 normal
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-26 04:19 UTC by Daniel Betschart
Modified: 2005-11-14 09:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Betschart 2003-05-26 04:19:55 UTC
I cannot execute a 32bit Windows program from a Samba share from a Windows XP
Client with SP 1. I receive the error message (translated from German to
Englisch) You don't have enough permissions to access the drive or path. If I
open a command window and try to execute the programm the error is simply:
Access denied. The same program from the same share I can run from a Windows NT
4.0 Workstation (SP 5) without any problem.
The permissions on the file on the Linux side are rw-rw---- and it owns to me.
If I show the permissions on the Windows NT 4.0 Workstation I see the RW, and if
I show it on the XP Client I see that Read and Write permissions are given. Even
if I change this permissions so that I have Execute permission or change the
mode under Linux to rwxrwxrwx I cannot execute a 32bit windows executable.
I have also tried to disable the NTFS permissions for this share, but it does
not help.
I have installed Samba 2.2.8a, but my problem still exists, so I revert to
2.2.7a. I have not tried older versions. When I had installed the first XP
client, I had already Samba 2.2.7a installed.
This affects not 16bit executables, only 32bit.
Comment 1 Bert Schinkel 2003-07-23 11:19:41 UTC
It might have something to do with you internet security settings. Please add 
your Samba Server to the "trusted network ressources". This should fix the 
Problem. To do so, open Internet Explorer, go to "Extras", "internet settigs",
"Security". Click on "Trusted Sites". Add your Samba server there. 
The "failure" you decribed is by design.
Comment 2 Daniel Betschart 2003-08-03 06:53:29 UTC
I added my Samba server to the trusted internet zone and activated all settings
by reducing the security level within this zome (enable ActiveX, low security
and so on), but it does not help. I removed my Samba server from the trusted
sites and reduced the security level of the local intranet zone. But this also
does not help.
What I make wrong? Don't you mean these settings within Internet Explorer?
Comment 3 Daniel Betschart 2003-08-21 06:38:26 UTC
In the meantime I have created a test environment with a SuSE Linux 7.3 Server
and a Windows XP Client away from my other production system.
With and without WinXP SP1 in this environment I can execute a Windows Binary
from a Samba Share. I can't understand this.
I have compared the smb.conf files and the only parameter that cames in question
to be the problem ist veto files. There I have added "/.X*/" in my production
environment to avoid seeing the configuration files in the home directories. I
will try to remove this and see the difference.
Comment 4 Daniel Betschart 2003-09-01 08:13:44 UTC
No, it is not the veto files parameter. It is the share parameter inherit
permissions!!! On all shares I use it, because each file or directory should
have the group assigned from the parent directory, which I have set up with set
guid.

If I remove inherit permissions or set it to no then I can execute a Windows
executable from the share. If inherit permissions is set to yes I receive the
message, that I have not enough permissions as described first.

On this special share I can remove inherit permissions without a problem. But I
think it is a bug, because from a Windows NT 4.0 client I can run Windows
programs even when inherit permissions ist set to true.
Comment 5 Gerald (Jerry) Carter 2003-09-02 06:24:59 UTC
Does this same behavior exists in 
the 3.0.0 release candidates?  We don't have 
a lot of resources to spare for 2.2 right now.
Comment 6 Daniel Betschart 2003-09-02 08:06:41 UTC
I will try it next weekend with RC2.
Comment 7 Daniel Betschart 2003-09-09 00:40:34 UTC
I had a little problem with Samba 3.0.0rc2: using the smbpasswd passdb Samba
needs the shared library smbpasswd.so, but I cannot find it in the samba souce
code. I used the tdb instead. Also if I create a new file on a share, the file
was not visible until I have made a refresh (F5) at the windows client.

Now the good news: the problem with inerit permissions occurs no more in
3.0.0rc2! That's very fine.
Comment 8 Gerald (Jerry) Carter 2004-02-17 08:45:47 UTC
Sorry, but the 2.2 is not under development any longer.
If you can reproduce this bug against the latest 3.0 release, 
please reopen this bug and change the version in the report.
Thanks.
Comment 9 Gerald (Jerry) Carter 2005-11-14 09:30:35 UTC
database cleanup