Bug 12685 - REGRESSION: net ads keytab handling is broken
REGRESSION: net ads keytab handling is broken
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Winbind
4.6.0rc4
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
: 12740 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-13 15:00 UTC by Andreas Schneider
Modified: 2017-04-12 07:28 UTC (History)
5 users (show)

See Also:


Attachments
patch for 4.6 (8.53 KB, patch)
2017-03-15 07:25 UTC, Andreas Schneider
gd: review+
asn: review? (abartlet)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Schneider 2017-03-13 15:00:55 UTC
net ads keytab handling is broken. We pass NULL to smb_krb5_kt_open() which is not allowed. In addition the 'dedicated keytab' option from smb.conf is not respected at all.
Comment 1 Andreas Schneider 2017-03-15 07:25:58 UTC
Created attachment 13061 [details]
patch for 4.6
Comment 2 Guenther Deschner 2017-03-15 11:56:34 UTC
Comment on attachment 13061 [details]
patch for 4.6

LGTM
Comment 3 Guenther Deschner 2017-03-15 11:57:16 UTC
Karolin, please add to 4.6, thanks!
Comment 4 Karolin Seeger 2017-03-23 11:25:03 UTC
(In reply to Guenther Deschner from comment #3)
Pushed to autobuild-v4-6-test.
Comment 5 Karolin Seeger 2017-03-27 09:36:24 UTC
(In reply to Karolin Seeger from comment #4)
Pushed to v4-6-test.
Closing out bug report.

Thanks!
Comment 6 Stefan Metzmacher 2017-04-12 07:28:22 UTC
*** Bug 12740 has been marked as a duplicate of this bug. ***