Bug 12651 - librpc/ndr/ndr_netlogon.c
librpc/ndr/ndr_netlogon.c
Status: RESOLVED DUPLICATE of bug 12625
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.6.0
x64 Mac OS X
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-11 17:34 UTC by Ruga
Modified: 2017-06-29 07:09 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruga 2017-03-11 17:34:48 UTC
[1141/3257] Compiling librpc/ndr/ndr_netlogon.c
../librpc/ndr/ndr_netlogon.c:29:8: warning: comparison of constant 255 with expression of type 'enum netr_SamDatabaseID' is always false [-Wtautological-constant-out-of-range-compare]
        if (r > 0xff) return NDR_ERR_BUFSIZE;
            ~ ^ ~~~~
../librpc/ndr/ndr_netlogon.c:49:8: warning: comparison of constant 255 with expression of type 'enum netr_DeltaEnum' is always false [-Wtautological-constant-out-of-range-compare]
        if (r > 0xff) return NDR_ERR_BUFSIZE;
            ~ ^ ~~~~
2 warnings generated.
Comment 1 Andrew Bartlett 2017-06-29 07:09:53 UTC

*** This bug has been marked as a duplicate of bug 12625 ***