Bug 12623 - dbwrap.c
dbwrap.c
Status: RESOLVED DUPLICATE of bug 11811
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.6.0
x64 Mac OS X
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-10 08:28 UTC by Ruga
Modified: 2017-05-30 16:17 UTC (History)
0 users

See Also:


Attachments
patch (280 bytes, patch)
2017-03-10 09:22 UTC, Ruga
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruga 2017-03-10 08:28:39 UTC
[1276/3257] Compiling lib/dbwrap/dbwrap.c
In file included from ../lib/dbwrap/dbwrap.c:26:
In file included from ../lib/dbwrap/dbwrap.h:27:
In file included from ../lib/param/loadparm.h:270:
default/lib/param/param_local.h:141:1: fatal error: field has incomplete type 'struct timespec'
LOADPARM_EXTRA_LOCALS
^
../lib/param/loadparm.h:264:18: note: expanded from macro 'LOADPARM_EXTRA_LOCALS'
        struct timespec usershare_last_mod;                             \
                        ^
default/lib/param/param_local.h:141:1: note: forward declaration of 'struct timespec'
../lib/param/loadparm.h:264:9: note: expanded from macro 'LOADPARM_EXTRA_LOCALS'
        struct timespec usershare_last_mod;                             \
               ^
1 error generated.
Waf: Leaving directory `/Volumes/Verbatim/opt/src/samba-4.6.0/bin'
Build failed:  -> task failed (err #1): 
        {task: cc dbwrap.c -> dbwrap_1.o}
make: *** [all] Error 1
Comment 1 Ruga 2017-03-10 09:22:33 UTC
Created attachment 13034 [details]
patch
Comment 2 Björn Jacke 2017-05-30 16:17:50 UTC
attaching a patch and close it as worksforme is not the right way to use bugzilla.

*** This bug has been marked as a duplicate of bug 11811 ***