Bug 12470 - ctdb ip bugs
ctdb ip bugs
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: CTDB
4.5.2
All All
: P5 normal
: ---
Assigned To: Karolin Seeger
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-12-15 02:40 UTC by Martin Schwenke
Modified: 2017-01-10 06:10 UTC (History)
3 users (show)

See Also:


Attachments
Patches for v4-5 (18.29 KB, patch)
2016-12-18 12:48 UTC, Amitay Isaacs
martins: review+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Schwenke 2016-12-15 02:40:59 UTC
There are several regressions in the "ctdb ip" code in 4.5.x:

* Output is not sorted when running "ctdb ip all"

* Memory corruption and associated crash when running "ctdb ip -v"

* Attempts to GET_PUBLIC_IP_INFO from CTDB_UNKNOWN_PNN for unhosted IPs

* "ctdb ip -v" prints 4294967295 instead of -1 for unhosted IPs

2 other issues were identified in the same code:

* "ctdb ip all" can incorrectly report IP assigned for addresses that have
  been released but for which takeover has failed on the target node.

* Information for IP addresses is printed in reverse sort order

  This has always been the case but is counter-intuitive.  It is worth
  fixing this while adding test cases...
Comment 1 Amitay Isaacs 2016-12-18 12:48:47 UTC
Created attachment 12773 [details]
Patches for v4-5
Comment 2 Martin Schwenke 2016-12-18 20:08:06 UTC
Hi Karolin,

This is ready for 4.5.

Thanks...
Comment 3 Karolin Seeger 2016-12-20 08:58:24 UTC
(In reply to Martin Schwenke from comment #2)
Pushed to autobuild-v4-5-test.
Comment 4 Karolin Seeger 2017-01-02 09:29:13 UTC
(In reply to Karolin Seeger from comment #3)
Pushed to v4-5-test.
Closing out bug report.

Thanks!
Comment 5 Amitay Isaacs 2017-01-10 06:10:39 UTC
*** Bug 12506 has been marked as a duplicate of this bug. ***