Bug 12435 - leaking files under private/msg.sock and var/lock/msg.lock
Summary: leaking files under private/msg.sock and var/lock/msg.lock
Status: NEW
Alias: None
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Other (show other bugs)
Version: 4.4.7
Hardware: All All
: P5 normal (vote)
Target Milestone: ---
Assignee: Andrew Bartlett
QA Contact: Samba QA Contact
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-18 14:00 UTC by YOUZHONG YANG
Modified: 2020-01-07 10:06 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description YOUZHONG YANG 2016-11-18 14:00:39 UTC
Reproduction: start samba, and then shut it down, you will see a bunch of files are left behind under private/msg.sock and var/lock/msg.lock. I've reproduced it on a illumos/opensolaris platform, haven't tried on Linux.
Comment 1 Volker Lendecke 2016-11-18 15:04:31 UTC
Hello!

Samba has provisions to clean up both directories regularly. Is it a major problem for you that we leave sfome files behind? Will they pile up indefinitely, or are they disappearing again when you restart Samba and what a while?

If it is a major showstopper for you, can you try to find out which daemons leave something behind?

With best regards,

Volker Lendecke

... who feels shitty having changed messaging at all. Sockets seemed to be a good idea, but they are just not reliable enough for production.
Comment 2 YOUZHONG YANG 2016-11-18 16:12:55 UTC
Thanks Volker.

It's not a blocker for us, I just feel the cleanup is not working properly. It seems the number of files piles up, and won't go away even after shutting down Samba.

I will try to figure out which daemon leaves those files behind when I get a chance.
Comment 3 Jeremy Allison 2016-11-18 16:59:45 UTC
(In reply to Volker Lendecke from comment #1)

> ... who feels shitty having changed messaging at all. Sockets seemed to be a 
> good idea, but they are just not reliable enough for production.

Nah, don't feel bad. We can't go back to tdb messaging. Making all the code signal-safe is a harder task than fixing socket issues, and I'm not sure we ever had it right.

Files left behind is a very minor issue compared with sig-safe code issues :-).
Comment 4 Patrice Damezin 2020-01-07 10:06:22 UTC
Hello,

i got this same issue only using smbclient on a proxmox PVE6.1 node (debian buster,  samba-common 2:4.9.5+dfsg-5+deb10u1 ).

Each time proxmox pvestatd service call smbclient, a file and a socket remain on both folder, after 1 month more than 300.000 files has been created and has never been cleaned, no samba service is running on the host to do that in background.

I dont really understand why smbclient is not cleaning file and socket in /var/run/samba/msg.lock/ and ./var/lib/samba/private/msg.sock.

Proxmox bug : https://bugzilla.proxmox.com/show_bug.cgi?id=2333

Here the command executed every 10 seconds by proxmox's pvestatd service :
/usr/bin/smbclient //remote.samba.server/samba-mountpoint -d 0 -m smb3 -U samba-username -A /etc/pve/priv/bpc.cred -c "echo 1 0"

Packages installed on proxmox node : 
dpkg -l |grep samba
ii  samba-common                         2:4.9.5+dfsg-5+deb10u1                          all          common files used by both the Samba server and client
ii  samba-libs:amd64                     2:4.9.5+dfsg-5+deb10u1                          amd64        Samba core libraries