Bug 1243 - Perfomance issue with samr_query_dom_info level 2 breaks winbind
Perfomance issue with samr_query_dom_info level 2 breaks winbind
Status: RESOLVED DUPLICATE of bug 1237
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2a
All All
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 08:26 UTC by John Janosik
Modified: 2005-02-07 07:42 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Janosik 2004-04-05 08:26:49 UTC
We are testing the migration of our NT4 domain to a Samba 3 Domain.  Our member
servers are currently running Samba 2.2.8a on RedHat linux 9.  After migrating
~800 groups and ~8000 user/computer accounts to the Samba 3 DC with an openldap
backend we cannot successfully start winbindd on a Samba 2.2.8a member server
joined to the migrated domain.

In a network trace between the member server and the DC I see a query_dom_info
level 2 call that never completes.  Looking in rpc_server/srv_samr_nt.c I see
that Samba is loading each sam entry and iterating through them to get a count
of users and groups.

I worked around the problem by adding two new functions to the ldap passdb
backend, pdb_getusercount and pdb_getgroupcount.  These just do one ldap query
to get the number of groups or users.

Is there a better way to approach this problem.  I could probably tune my
openldap server better to avoid the timeout but I worry that won't work if we
want to scale to 100,000s of users.
Comment 1 John Janosik 2004-04-05 08:49:25 UTC
This is a duplicate of 1237.  I accidentally refreshed the wrong page and
submitted twice.
Comment 2 Gerald (Jerry) Carter 2004-04-22 20:30:07 UTC

*** This bug has been marked as a duplicate of 1237 ***
Comment 3 Gerald (Jerry) Carter 2005-02-07 07:39:55 UTC
originally reported against 3.0.3pre1.  Moving back to version to 3.0.2a
to remove preX and rcX versions.
Comment 4 Gerald (Jerry) Carter 2005-02-07 07:42:16 UTC
originally reported against 3.0.3pre2.  Moving back to version to 3.0.2a
to remove preX and rcX versions.