Bug 12411 - vfs_fruit configuration variable "resource" is spelled "ressource" in code
vfs_fruit configuration variable "resource" is spelled "ressource" in code
Status: RESOLVED DUPLICATE of bug 12412
Product: Samba 4.1 and newer
Classification: Unclassified
Component: VFS Modules
4.5.1
All All
: P5 minor
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-07 23:08 UTC by Aaron Laffin
Modified: 2016-12-05 21:06 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Laffin 2016-11-07 23:08:04 UTC
According to the fruit man page, there is a configuration variable, fruit:resource, which affects behavior relating to storage of resource fork data. Despite the man page spelling of "resource", it is spelled "ressource" in the code. See vfs_fruit.c:1313 below.

The downside of this inconsistency is that the variable doesn't appear to affect behavior as functionality remains in the default mode.

4.5.1 source3/modules/vfs_fruit.c:

  1300  static int init_fruit_config(vfs_handle_struct *handle)
  1301  {
  1302          struct fruit_config_data *config;
  1303          int enumval;
  1304  

...

  1311  
  1312          enumval = lp_parm_enum(SNUM(handle->conn), FRUIT_PARAM_TYPE_NAME,
  1313                                 "ressource", fruit_rsrc, FRUIT_RSRC_ADFILE);
  1314          if (enumval == -1) {
  1315                  DEBUG(1, ("value for %s: ressource type unknown\n",
  1316                            FRUIT_PARAM_TYPE_NAME));
  1317                  return -1;
  1318          }
  1319          config->rsrc = (enum fruit_rsrc)enumval;
Comment 1 Aaron Laffin 2016-12-05 21:06:16 UTC
Noticed that this is fixed in master under bug 12412.

Resolving as duplicate.

*** This bug has been marked as a duplicate of bug 12412 ***