Bug 12406 - Raising the forest functional level to 2012/2012_R2 fails
Raising the forest functional level to 2012/2012_R2 fails
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Tools
4.5.0
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-02 17:28 UTC by Marc Muehlfeld
Modified: 2016-12-08 21:48 UTC (History)
2 users (show)

See Also:


Attachments
samba-tool level 10 debug log (4.51 KB, text/x-log)
2016-11-02 17:28 UTC, Marc Muehlfeld
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Muehlfeld 2016-11-02 17:28:03 UTC
Created attachment 12627 [details]
samba-tool level 10 debug log

On my existing DC (provisioned with 4.1.11, constantly updated and currently runs 4.5.0), raising the domain level to 2012_R2 fails:
# samba-tool domain level raise --domain-level=2012_R2
ERROR: Domain function level can't be higher than the lowest function level of a DC!

Raising up to 2008_R2 works. 2012 and 2012_R2 fails.

On this Samba AD I see:
dn: DC=samdom,DC=example,DC=com
msDS-Behavior-Version: 2




If I provision a new Samba AD with 4.5.0:
dn: DC=samdom,DC=example,DC=com
msDS-Behavior-Version: 4
Seems it has a new default, and it is not raised in existing Samba ADs if you update Samba.

However, raising the level from default (2008_R2) fails here, too.
Comment 1 Stefan Metzmacher 2016-11-03 05:53:49 UTC
We simply don't support 2012* yet.