Bug 12401 - Printer driver error "The folder you specified doesn't contain a compatible software driver for your device"
Printer driver error "The folder you specified doesn't contain a compatible s...
Status: RESOLVED FIXED
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Printing
4.3.11
x64 Linux
: P5 normal
: ---
Assigned To: printing-maintainers
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-31 09:17 UTC by Maxim
Modified: 2016-11-09 11:48 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim 2016-10-31 09:17:52 UTC
This problem is described and partially solved on the official manual page:
https://wiki.samba.org/index.php/Configuring_Point%27n%27Print_automatic_printer_driver_deployment
and here:
http://serverfault.com/questions/573411/why-cant-i-upload-drivers-to-my-samba-print-server

The root of the problem is that Kyocera Manufacturer lists its drivers as NTx86.5.1, NTx86.6.0, NTamd64.5.1, NTamd64.6.0 instead of simple NTx86 and NTx64 and samba server doesn't seem to know anything except NTx86 and NTx64.

The solution with manual editing of the ".inf" file goes well only when you install such a modified printer driver on a couple of computers. You can manually override the "unsigned driver" warning.
If you are going to install these drivers to hundreds of computers through the group policy it can become a nightmare. The modified ".inf" file causes denial of driver installation on windows 7 64 bit (at least) and it can't be ignored or overridden by the group policy.
Comment 1 Andreas Schneider 2016-11-08 17:50:48 UTC
Where can we download the driver?
Comment 2 Maxim 2016-11-09 05:44:48 UTC
(In reply to Andreas Schneider from comment #1)

Here:
http://www.kyocerasupport.co.uk/index/download_center.false._.FS1028MFP._.EN.html

Choose "KX driver (certified and signed by Microsoft)" for Windows 7.
Comment 3 Andreas Schneider 2016-11-09 11:04:11 UTC
The driver specifies:

[Manufacturer]
"Kyocera"=Kyocera,NTx86.5.1,NTx86.6.0,NTamd64.5.1,NTamd64.6.0

This means it is for Windows version 5.1 and 6.0. The spoolss server announces itself by default as 5.0. See

rpcclient //PRINTSERVER -Uadministrator%secret -c "getdata . Osversion"


If you change the smb.conf and set in the [global] section:

        spoolss:os_major = 5
        spoolss:os_minor = 1


It should work. Please try and report back. Thanks!
Comment 4 Andreas Schneider 2016-11-09 11:45:20 UTC
This fixes the issue with the version number but the driver still cannot be uploaded because of a missing feature, see bug #12415
Comment 5 Maxim 2016-11-09 11:48:49 UTC
(In reply to Andreas Schneider from comment #4)

So there is no need at the moment for me to try it by myself on the test machine again, isn't it?