Bug 12365 - In call_trans2qfilepathinfo call lstat when dealing with posix pathnames
In call_trans2qfilepathinfo call lstat when dealing with posix pathnames
Status: RESOLVED DUPLICATE of bug 12256
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
unspecified
All All
: P5 normal
: ---
Assigned To: Ralph Böhme
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-05 15:07 UTC by Ralph Böhme
Modified: 2016-10-05 15:09 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Böhme 2016-10-05 15:07:57 UTC
Bugreport for backport of commit b13b3c11054f918f18841186a6efc5dedd2ffd66:

This might be an info level SMB_INFO_QUERY_ALL_EAS which is not covered by INFO_LEVEL_IS_UNIX(). If smb_fname is a symlink we would then stat it in POSIX context.
Comment 1 Ralph Böhme 2016-10-05 15:09:17 UTC

*** This bug has been marked as a duplicate of bug 12256 ***