Bug 1236 - Directory Permissions
Directory Permissions
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2a
All Windows 2000
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 05:50 UTC by Simon Wood
Modified: 2005-08-24 10:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Wood 2004-04-02 05:50:40 UTC
It seems even under 3.0.3pr1 that the directory ownership problem. Still exists.
 All directories seem to owned by root.

I am running a ldap for my account information.  Can anone shed some light on
this matter?

Simon Wood
Comment 1 Gerald (Jerry) Carter 2004-04-02 06:51:01 UTC
please provide much more infortmation such 
as smb.conf, level 10 log files, etc....
Comment 2 Simon Wood 2004-04-02 08:16:52 UTC
smb.conf

# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2003/12/19 15:40:55

# Global parameters
[global]
        
	passdb backend = ldapsam:ldap://localhost
	idmap backend = ldap:ldap://localhost
	#idmap only = yes
	ldap filter = (&(uid=%u)(objectclass=sambaSAMAccount))
	ldap suffix = dc=lan,dc=terabyte-computing,dc=com
	ldap machine suffix = ou=Computers
	ldap user suffix = ou=People
	ldap group suffix = ou=Group
	ldap admin dn = "cn=Manager,dc=lan,dc=terabyte-computing,dc=com"
	ldap ssl = No
	ldap delete dn = no
	#ldap trust ids = yes
	domain admin group = +Domain Admins,+Administrators
	domain admin users = root
	netbios name = server1
	workgroup = LAN
	os level = 255
	max log size = 50
	socket options = SO_KEEPALIVE SO_REUSEADDR SO_BROADCAST TCP_NODELAY
IPTOS_LOWDELAY IPTOS_THROUGHPUT SO_RCVBUF=8192 SO_SNDBUF=8192
	logon drive = H:
	null passwords = yes
	domain master = Yes
	encrypt passwords = yes
	logon path = \\%N\profiles\%g
	wins support = Yes
	comment = Server1 - A Real Server on A Real OS
	preferred master = Yes
	domain logons = Yes
	security = domain
	unix charset = UTF-8
	dos charset = CP850
	display charset = LOCALE
	log file = /var/log/samba/%m.log
	passwd program = /usr/local/bin/smbldap-passwd.pl -o %u
        passwd chat = *new*password* %n\n *new*password:* %n\ *successfully*
        passwd chat debug = Yes
	map to guest = Never
	
        add user script = /usr/local/sbin/smbldap-useradd.pl -a "%u"
        delete user script = /usr/local/sbin/smbldap-useradd.pl -d "%u"
        add group script = /usr/local/sbin/smbldap-useradd.pl -a -g "%g"
        delete group script = /usr/local/sbin/smbldap-useradd.pl -d -g "%g"
        add user to group script = /usr/local/sbin/smbldap-useradd.pl -j -u "%u"
-g "%g"
        delete user from group script = /usr/local/sbin/smbldap-useradd.pl -j -u
"%u" -g "%g"
        set primary group script = /usr/local/sbin/smbldap-useradd.pl -m -u "%u"
-gid "%g"
        add machine script = /usr/local/sbin/smbldap-useradd.pl -a -w "%m"

[homes]
	comment = Home Directories
	#create mask = 0664
	#directory mask = 0775
	browseable = yes

The logs dont tell you very much but would be happy to email em if needs be..
Comment 3 Gerald (Jerry) Carter 2004-04-22 19:45:08 UTC
I cannot reproduce this locally.  So we will need level 10 debug logs
of you createing a file that has the incorrect ownership and the 
output from ls -lRF on the directories in quesion.

Comment 4 Gerald (Jerry) Carter 2005-02-07 07:46:51 UTC
no feedback.  Closing as fixed.  changing version to 
3.0.2a (originally 3.0.3pre1) in order to clear out 
preXand rcX versions.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:20:27 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.