Bug 1235 - Login Permission Failed
Login Permission Failed
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
All Windows 2000
: P4 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 11:17 UTC by me
Modified: 2005-08-24 10:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description me 2004-04-01 11:17:13 UTC
We have a sql agent job (SQL Server 2000 on a Windows 2003 platform ) that BCP 
out using a UNC path through Samba to a linux box. The username and passowrd to 
connect is in a domain. For the most part, the job BCP (exports) out the output 
with no problem, however, in some instances, the permission/connection gets 
interrupted. The SQL agent auto sends a notification of the error of BCPing out 
the file, and once the notification is received, I go to the server where SQL 
Server resides, and try to connect to the Linux server where the file is being 
stored. I get a pop up box requiring me to enter the username and password, 
when I enter the username and password, it informs me that it's invalid. 
However, after a certain amount of time (sometimes only 5 mins, but other 
times, it's 1-2 hrs.), I get my permission/connection back, with the same 
username and password of course.

Thanks.
Comment 1 Gerald (Jerry) Carter 2004-04-22 19:41:32 UTC
should already be fixed in 3.0.1 or later IIRC.
Comment 2 Ignasi Forcada 2005-07-07 07:10:56 UTC
This was reported as a bug in Samba 3.0.0 and I would be very much interested 
in knowing if you have found a solution for it, since we have a similar 
behaviour with Samba 2.2.12. Could it just be a communication problem with the 
password server and not a bug in Samba?

Here the logged messages with debug level 3

[2005/07/05 17:18:36, 3] smbd/process.c:process_smb(846)
  Transaction 111 of length 194
[2005/07/05 17:18:36, 3] smbd/process.c:switch_message(685)
  switch message SMBsesssetupX (pid 9)
[2005/07/05 17:18:36, 3] smbd/sec_ctx.c:set_sec_ctx(329)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2005/07/05 17:18:36, 3] smbd/reply.c:reply_sesssetup_and_X(880)
  Domain=[TURBOS]  NativeOS=[Windows 2000 2195] NativeLanMan=[Windows 2000 5.0]
[2005/07/05 17:18:36, 3] smbd/reply.c:reply_sesssetup_and_X(890)
  sesssetupX:name=[MNL]
[2005/07/05 17:18:36, 3] lib/username.c:map_username(168)
  Mapped user MNL to patools
[2005/07/05 17:18:36, 1] smbd/password.c:server_validate(1102)
  password server  is not connected
[2005/07/05 17:18:36, 1] smbd/password.c:pass_check_smb(545)
  Couldn't find user 'patools' in passdb.
[2005/07/05 17:18:36, 2] smbd/reply.c:reply_sesssetup_and_X(997)
  NT Password did not match for user 'patools'!
[2005/07/05 17:18:36, 2] smbd/reply.c:reply_sesssetup_and_X(1007)
  Defaulting to Lanman password for patools
[2005/07/05 17:18:36, 1] smbd/password.c:pass_check_smb(545)
  Couldn't find user 'patools' in passdb.
[2005/07/05 17:18:36, 1] smbd/reply.c:reply_sesssetup_and_X(1023)
  Rejecting user 'patools': authentication failed
[2005/07/05 17:18:36, 3] smbd/error.c:error_packet(94)
  error string = File or directory doesn't exist
[2005/07/05 17:18:36, 3] smbd/error.c:error_packet(113)
  error packet at smbd/reply.c(1025) cmd=115 (SMBsesssetupX) 
NT_STATUS_LOGON_FAILURE
Comment 3 Gerald (Jerry) Carter 2005-08-24 10:27:45 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.