Bug 1229 - Being in too many groups gives "access is denied" to all groups.
Being in too many groups gives "access is denied" to all groups.
Status: RESOLVED DUPLICATE of bug 1081
Product: Samba 3.0
Classification: Unclassified
Component: File Services
All Solaris
: P2 major
: none
Assigned To: Samba Bugzilla Account
Depends on:
  Show dependency treegraph
Reported: 2004-03-30 05:21 UTC by Peter Saunders
Modified: 2005-11-14 09:27 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Saunders 2004-03-30 05:21:49 UTC
Via samba, if a user is in 16 unix groups, and the user then attempts to go into 
a directory where they rely on the group permission letting them in, they get 
access is denied. A small snipit of truss output below:

stat64("proj/gc", 0xFFBFD890)                   = 0
send(16, "\0\0\0 dFF S M B 2\0\0\0".., 104, 0)  = 104
time()                                          = 1080646263
poll(0xFFBFE9A8, 3, 60000)                      = 1
read(16, "\0\0\0 f", 4)                         = 4
read(16, "FF S M B 2\0\0\0\01807C8".., 102)     = 102
stat64("proj/gc", 0xFFBFE078)                   = 0
stat64("proj/gc/*", 0xFFBFE078)                 Err#13 EACCES
stat64("proj/gc/*", 0xFFBFE078)                 Err#13 EACCES

This user DOES have permission to go to this directory (can su to them, and then 
go in). By reducing the number of groups they are in to less than 16, they then 
get granted access.
Comment 1 Gerald (Jerry) Carter 2004-03-31 07:50:40 UTC

*** This bug has been marked as a duplicate of 1081 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:27:51 UTC
database cleanup