Bug 12267 - Samba becomes unresponsive after upgrade to 4.5.0
Samba becomes unresponsive after upgrade to 4.5.0
Status: RESOLVED DUPLICATE of bug 12045
Product: Samba 4.1 and newer
Classification: Unclassified
x64 Linux
: P5 critical
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2016-09-15 10:03 UTC by Sander Plas
Modified: 2016-09-16 10:29 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Sander Plas 2016-09-15 10:03:08 UTC
We have 10 school buildings on a Samba 4 domain. The buildings are connected in a VPN. Each building has its own Samba 4 Domain Controller on an Ubuntu server. 

Our workstations are mainly Windows 10, but there are still some Windows 8.1 workstations around. 

Since the upgrade to Samba 4.5.0, we started seeing this problem. About once or twice a day, samba stops responding correctly on a random server/location.  

The symptoms: 
- logging in on a workstation takes forever (hangs on 'applying policy <something>') 
- shares stop working
- DNS stops working (we're using internal DNS)
- "wbinfo -i <username>" stops working (hangs)

When i try to shutdown samba, a lot of smb processes keep on running. The only way to shut them down is using "kill -9" or by rebooting the whole server. 

After starting samba again, everyting starts working again. 

If there's anything i can do to collect more information, please let me know.
Comment 1 Sander Plas 2016-09-16 10:29:27 UTC
After looking at more logs, i think my problem is a duplicate of # 12045 .

*** This bug has been marked as a duplicate of bug 12045 ***