Bug 12253 - Upgrading to 4.5 from 4.4 and server will not start
Upgrading to 4.5 from 4.4 and server will not start
Product: Samba 4.1 and newer
Classification: Unclassified
Component: File services
x86 Linux
: P5 critical
: ---
Assigned To: Samba QA Contact
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2016-09-10 21:28 UTC by Patrick Houle
Modified: 2016-09-10 22:01 UTC (History)
1 user (show)

See Also:

systemctl status, smbd.log, testparm, journalctl -xe (10.61 KB, text/plain)
2016-09-10 21:28 UTC, Patrick Houle
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Houle 2016-09-10 21:28:07 UTC
Created attachment 12457 [details]
systemctl status, smbd.log, testparm, journalctl -xe

Arch Linux. A little problem since the update from 4.4 to 4.5 yesterday (9/9/16). The samba server will not start now. I have tried downgrading back to 4.4, but then a whole different set of problems occur. I have renamed my smb.conf to smb.conf.old and used the default conf with my own paths (homes and Shares). Various log and test files copied to attachment.
Comment 1 Patrick Houle 2016-09-10 21:46:09 UTC
pat@Server:~$ samba --version
Version 4.5.0
pat@Server:~$ uname -a
Linux Server 4.4.20-1-lts #1 SMP Wed Sep 7 22:03:08 CEST 2016 x86_64 GNU/Linux
Comment 2 Patrick Houle 2016-09-10 22:01:58 UTC
It was a package pulled in and updated the same day, tevent-0.9.30. Downgrading to 0.9.29 fixed the issue.