Bug 1222 - Print Server With Samba Not Working
Print Server With Samba Not Working
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.0
All Linux
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
:
: 1223 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-28 14:21 UTC by josh kotecha
Modified: 2004-06-03 11:39 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description josh kotecha 2004-03-28 14:21:39 UTC
I have a Windows XP system. I have a Linux system. The Linux system is connect 
to an HP Printer (Deskjet 820cxi) with a parallel port.  I have added a share 
for all printers in the smb.conf file. Here is the setup:

printcap name = /etc/printcap
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
load printers = yes
dns proxy = no
log file = /var/log/samba/%m.log
printer = printer
path = /var/spool/samba
workgroup = MSHOME


and then below this I have:

[printers]
        path = /var/spool/samba
        comment = All Printers
        printable = yes
        public = yes


Now I can see the printer on this machine on my XP system. I can also see it 
when I do smbtree on the Linux system.

When I print a document, I open the print queue on the windows XP machine. I 
can see the document and then a few seconds its deleted. However, nothing 
shows up on the printer.

I looked in the log for the XP machine: accord.log 
under /var/log/samba/accord.log where accord is the name of the windows XP 
client I'm trying to print from.

Here is the output of that log file:
[2004/03/28 15:17:04, 1] smbd/service.c:make_connection_snum(698)
  accord (192.168.0.2) connect to service jfk initially as user jfk (uid=500, 
gi
d=500) (pid 12060)
[2004/03/28 15:17:34, 0] smbd/service.c:make_connection(850)
  accord (192.168.0.2) couldn't find service ::{2227a280-3aea-1069-a2de-
08002b30
309d}
[2004/03/28 15:22:58, 1] smbd/service.c:make_connection_snum(698)
  accord (192.168.0.2) connect to service printer initially as user jfk 
(uid=500
, gid=500) (pid 12060)
lpr: unable to print file: client-error-document-format-not-supported
[2004/03/28 15:23:09, 1] smbd/service.c:close_cnum(880)
  accord (192.168.0.2) closed connection to service printer
[2004/03/28 15:25:54, 1] smbd/service.c:make_connection_snum(698)
  accord (192.168.0.2) connect to service printer initially as user jfk 
(uid=500
, gid=500) (pid 12060)
lpr: unable to print file: client-error-document-format-not-supported
[2004/03/28 15:26:06, 1] smbd/service.c:close_cnum(880)
  accord (192.168.0.2) closed connection to service printer
[2004/03/28 15:35:10, 1] smbd/service.c:make_connection_snum(698)
  accord (192.168.0.2) connect to service printer initially as user jfk 
(uid=500
, gid=500) (pid 12060)
lpr: unable to print file: client-error-document-format-not-supported
[2004/03/28 15:35:22, 1] smbd/service.c:close_cnum(880)
  accord (192.168.0.2) closed connection to service printer

Now when I type 
lpr <<file>> e.g. lpr smbd.pdf  I have no problem. The file shows up on the 
printer.

I cant figure out why this isn't working.

Thanks
josh
p.s. I'm running the latest Fedora (Red Hat Linux).
Comment 1 Tim Potter 2004-03-29 03:46:33 UTC
*** Bug 1223 has been marked as a duplicate of this bug. ***
Comment 2 Gerald (Jerry) Carter 2004-03-31 07:41:31 UTC
from josh :

Here is a clue. It seems that Window XP formats the
file before its sent to the printer. So when the
printer is activated and the file is sent to the
remote printer via samba, the file format is not
acceptable to lpr.

Somehow, the samba system or the XP client needs to be
told how to not do anything. If its on the samba side
then it needs to be told to ignore the format and just
send it to lpr printer. If it is XP then XP needs to
be told not to format the file, but let samba take
care of it.

Comment 3 Gerald (Jerry) Carter 2004-06-03 11:39:48 UTC
If this is an issue with the format of print job
then this is a configuration issue and not a source bug.
Please reread the documentation for more details.