Bug 12188 - samba-tool error while enabled log level debug classes
samba-tool error while enabled log level debug classes
Status: RESOLVED DUPLICATE of bug 9945
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Tools
4.2.3
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-29 10:11 UTC by Yuriy Tabolin
Modified: 2016-09-16 09:01 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuriy Tabolin 2016-08-29 10:11:42 UTC
Problem: when enabled debug classes log level in smb4.conf, like

log level = 8 winbind:13

testparm checking ok, samba starts and works fine. But forced drs replication via samba-tool failed.

# samba-tool drs replicate dc3.speechpro.com dc1.speechpro.com dc=speechpro,dc=com

ERROR(<type 'exceptions.ValueError'>): DRS connection to dc3.speechpro.com failed - invalid literal for int() with base 10: '8 winbind:13'
File "/usr/local/lib/python2.7/site-packages/samba/netcmd/drs.py", line 39, in drsuapi_connect
(ctx.drsuapi, ctx.drsuapi_handle, ctx.bind_supported_extensions) = drs_utils.drsuapi_connect(ctx.server, ctx.lp, ctx.creds)
File "/usr/local/lib/python2.7/site-packages/samba/drs_utils.py", line 47, in drsuapi_connect
if int(lp.get("log level")) >= 5:

After that error samba stops to work and I need to restart it.
Comment 1 Christian Ambach 2016-09-16 09:01:28 UTC

*** This bug has been marked as a duplicate of bug 9945 ***