Bug 12162 - ldb utils need ldif-wrap option
ldb utils need ldif-wrap option
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2016-08-18 06:30 UTC by Maxim Vasiliev
Modified: 2016-08-19 12:09 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Vasiliev 2016-08-18 06:30:59 UTC
Both ldbsearch and ldbedit do ldif wrapping, but has no option to disable it.

When database contain utf8 values, they are ase64 encoded, can get very long, and wrapped by the utils. 
Using ldbsearch requires additional utility to unwrap lines (and decode utf).
Using ldbedit is impossible.