Bug 12148 - errors Compiling IDL librpc/idl/winbind.idl
errors Compiling IDL librpc/idl/winbind.idl
Status: RESOLVED DUPLICATE of bug 12142
Product: Samba 4.1 and newer
Classification: Unclassified
Component: Build
4.4.5
All All
: P5 normal
: ---
Assigned To: Samba QA Contact
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-12 15:59 UTC by s3
Modified: 2016-08-15 09:57 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description s3 2016-08-12 15:59:58 UTC
...
[ 215/3582] Compiling IDL librpc/idl/winbind.idl
/Volumes/home/opt/src/samba-4.4.5/librpc/idl/winbind.idl:183: warning: [out] argument `validation' not a pointer
/Volumes/home/opt/src/samba-4.4.5/librpc/idl/winbind.idl:185: warning: [out] argument `authoritative' not a pointer
/Volumes/home/opt/src/samba-4.4.5/librpc/idl/winbind.idl:183: error: winbind_SamLogon: [out] argument 'validation' is not a pointer or array, skip client functions
[ 216/3582] Compiling IDL source4/librpc/idl/irpc.idl
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:28: warning: subcontext() is deprecated. Use represent_as() or transmit_as() instead
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:70: warning: [out] argument `info' not a pointer
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:83: warning: top-level [out] pointer `dcname' is not a [ref] pointer
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:91: warning: [out] argument `num_addrs' not a pointer
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:113: warning: [out] argument `generic_reply' not a pointer
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:159: warning: [out] argument `info' not a pointer
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:70: error: nbtd_information: [out] argument 'info' is not a pointer or array, skip client functions
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:83: error: nbtd_getdcname: [out] argument 'dcname' is a pointer to type 'string', skip client functions
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:91: error: nbtd_proxy_wins_challenge: [out] argument 'num_addrs' is not a pointer or array, skip client functions
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:113: error: kdc_check_generic_kerberos: [out] argument 'generic_reply' is not a pointer or array, skip client functions
/Volumes/home/opt/src/samba-4.4.5/source4/librpc/idl/irpc.idl:159: error: smbsrv_information: [out] argument 'info' is not a pointer or array, skip client functions
[ 217/3582] Compiling IDL source4/librpc/idl/ntp_signd.idl
...
Comment 1 s3 2016-08-15 09:57:52 UTC

*** This bug has been marked as a duplicate of bug 12142 ***