Bug 12061 - libsmbclient regressions
libsmbclient regressions
Status: RESOLVED WORKSFORME
Product: Samba 4.1 and newer
Classification: Unclassified
Component: libsmbclient
4.4.2
All All
: P5 normal
: ---
Assigned To: Stefan Metzmacher
Samba QA Contact
:
Depends on: 11849
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-02 09:58 UTC by Stefan Metzmacher
Modified: 2017-08-16 09:48 UTC (History)
17 users (show)

See Also:


Attachments
Trace of a good and a broken smbclient (20.72 KB, application/gzip)
2016-08-23 14:15 UTC, Florent V
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Metzmacher 2016-08-02 09:58:41 UTC
+++ This bug was initially created as a clone of Bug #11849 +++

Hi,
I'm not sure, but I think that the version of the patch that is currently already checked in broke something.

I'm used to do discovery of local devices like that:
smbclient -N -L localhost

Then look for the master of the workgroup (let's say BIGMASTER) and do:
smbclient -N -L BIGMASTER

...
Comment 1 Florent V 2016-08-23 14:15:18 UTC
Created attachment 12393 [details]
Trace of a good and a broken smbclient

Hi,

Sorry for the long delay to generate the traces.

Following the discussion on #11849, here are the requested logs.

Test 1 and 2 are done with an unmodified version of Samba 4.2.12.
Test 3 is done with a modified version where I reverted the second part of the following patch:
https://git.samba.org/?p=samba.git;a=commitdiff;h=e72ad193a53e20b769f798d02c0610f91859bd38

"R4-BACKUP-1" is the client performing the request.
"5BIGBACKUPSOFT" is the device target that present the issue.
"LINKSYS08959" (not important), it is the network router, that is now the master of the isolated network. 

I don't think that the "Test2" will be relevant anymore as I had to change of network for an isolated one to generate the traces but so the workgroup "master" changed to be the network router and not anymore the 5bigbackupsoft.

Let me know if there is something else that I can do to help you investigate this issue.
Comment 2 Florent V 2016-09-21 10:22:25 UTC
Hi @Stefan,
Is it possible for you to have a look at my traces to see if there could be something interesting inside them?
Comment 3 Florent V 2017-01-09 15:16:20 UTC
Hi @Stefan,

Do you have an idea for my issue, or do you need more info?

Thank you
Comment 4 Stefan Metzmacher 2017-08-16 09:48:28 UTC
(In reply to Florent V from comment #3)

Somehow the Windows server behaves different depending on an
anonymous session setup with or without extended security.

In the broken case the server just returns ERROR_NO_BROWSER_SERVERS_FOUND (6118), but I can't reproduce that with Windows 2000sp4, Windows Server 2003 3790,
or Windows Server 2008 R2 Enterprise 7601 Service Pack 1.

Maybe ERROR_NO_BROWSER_SERVERS_FOUND is just a temporary error,
also got ERROR_REQ_NOT_ACCEP (71) once and a few seconds later it worked.

I'll close this for now as I don't we can do anything here.