Bug 12019 - Upgrade to Samab44 from Samba43 fails
Upgrade to Samab44 from Samba43 fails
Status: RESOLVED WORKSFORME
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.4.4
All FreeBSD
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-12 16:59 UTC by James B. Byrne
Modified: 2016-12-05 14:55 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James B. Byrne 2016-07-12 16:59:37 UTC
Following an in-place upgrade of Samba 4.3 to 4.4 samba-server fails to start throwing the following error messages:

</pre>
[2016/07/12 12:25:03.304919,  0] ../source4/smbd/server.c:373(binary_smbd_main)
  samba version 4.4.3 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2016
[2016/07/12 12:25:03.728929,  0] ../source4/smbd/server.c:485(binary_smbd_main)
  samba: using 'standard' process model
[2016/07/12 12:25:03.755748,  0] ../source4/smbd/service.c:98(server_service_startup)
  Failed to start service 'smb' - NT_STATUS_INVALID_SYSTEM_SERVICE
[2016/07/12 12:25:03.760020,  0] ../lib/util/become_daemon.c:111(exit_daemon)
  STATUS=daemon failed to start: Samba failed to start services, error code -1073741796
</pre>

smb4.conf
<pre>
[root@samba-02 ~]# cat /usr/local/etc/smb4.conf
# Global parameters
[global]
        workgroup = BROCKLEY-2016
        realm = BROCKLEY-2016.HARTE-LYNE.CA
        netbios name = SAMBA-02
        server role = active directory domain controller
        dns forwarder = 192.168.8.66
        server services = rpc, nbt, wrepl, ldap, cldap, kdc, drepl, winbindd, ntp_signd, kcc, dnsupdate, dns, smb
        dcerpc endpoint servers = epmapper, wkssvc, rpcecho, samr, netlogon, lsarpc, spoolss, drsuapi, dssetup, unixinfo, browser, eventlog6, backupkey, dnsserver, winreg, srvsvc
        idmap_ldb:use rfc2307 = yes

[netlogon]
        path = /var/db/samba4/sysvol/brockley-2016.harte-lyne.ca/scripts
        read only = No

[sysvol]
        path = /var/db/samba4/sysvol
        read only = No
</pre>
Comment 1 James B. Byrne 2016-07-13 13:41:04 UTC
I discovered that the --use-ntfs option is not supported in samba-4.4. When the original 4.3 install was done it was performed on a zfs backing store which required the use of that switch.  I suspect that a samba-4.4 upgrade cannot be made to such a configuration.

I have searched for any discussion of this and have found nothing other than a single report to the FreeBSD Ports maintainer for Samba regarding the missing option.  My present understanding is the zfs file systems are not supported by samba-4.4 when used as an AD-DC and as such the ufs store must be employed instead.  If I am wrong I would appreciate guidance on how to proceed to reslove this.

I was unable t find any Samba4 changelog mentioning the removal of --use-ntfs.  Could ypou point me to it please?
Comment 2 James B. Byrne 2016-07-27 20:48:08 UTC
This appears to be an issue which is known to the samba ports maintainer for FreeBSD and for which there is as yet not remedy.  We are therefore running on Samba43.
Comment 3 Björn Jacke 2016-12-05 14:55:27 UTC
see vfs_zfsacl. Closing this one as this is not a bug. Please consult the mailing list on how to use zfs with Samba.