Bug 12010 - Join SAMBA4 to AD DC. DNS not repy
Join SAMBA4 to AD DC. DNS not repy
Status: NEW
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.3.1
x64 Linux
: P5 critical
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-05 00:04 UTC by gelier
Modified: 2016-07-08 09:12 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gelier 2016-07-05 00:04:01 UTC
Hello,

It turns out that I'm trying to migrate a server Windows Server 2008 R2 with AD DC, to a CentOS 7 Samba4.
Until now it works perfectly migration of users, as well, that are synchronized and when I create a user on a server, on the other is reflected immediately.
The problem is that the DNS records are not migrated because they simply are creating a file called /usr/local/samba/private/named.conf.update.
Also I need that when you turn off WIN2008R2 and only stays on the CentOS you can join computers to the domain, for this I must have configured the DNS on CentOS machine.
I have tried to apply the following command:

# Samba-tool samdom.example.com domain join DC -Uadministrator --realm = SAMDOM.EXAMPLE.COM

This command is all arranged as above explain.
Because of this I then tried this command:

# Samba-tool samdom.example.com domain join DC -Uadministrator --realm = SAMDOM.EXAMPLE.COM --dns-backend = BIND9_DLZ

But now I have a new error saying not find DNS zones.
I greatly appreciate you can help me with this error, or helping me with a more accurate method to achieve the objective that I have proposed.
Comment 1 Arcadiy Ivanov 2016-07-08 09:12:51 UTC
From your description it sounds that you need to try the workaround here: https://wiki.samba.org/index.php/Samba_AD_DC_Troubleshooting#DNS_Replication_from_Windows_AD_DC_fails

I had to.