Bug 12000 - net rpc join regression after upgrade to samba 4.2.10
net rpc join regression after upgrade to samba 4.2.10
Status: RESOLVED DUPLICATE of bug 11982
Product: Samba 4.1 and newer
Classification: Unclassified
Component: DCE-RPCs and pipes
4.2.10
All All
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-29 14:48 UTC by Heinrich Mislik
Modified: 2016-07-01 11:08 UTC (History)
1 user (show)

See Also:


Attachments
output of testparm -v (4.2.3) (10.34 KB, application/x-troff-man)
2016-06-29 14:48 UTC, Heinrich Mislik
no flags Details
output of net -d 5 rpc join -U pdcadm7 (4.2.3) (21.62 KB, text/plain)
2016-06-29 14:50 UTC, Heinrich Mislik
no flags Details
tcpdump of net -d 5 rpc join -U pdcadm7 (4.2.3) (35.06 KB, application/vnd.tcpdump.pcap)
2016-06-29 14:51 UTC, Heinrich Mislik
no flags Details
output of testparm -v (4.2.10) (10.61 KB, text/plain)
2016-06-29 14:51 UTC, Heinrich Mislik
no flags Details
output of net -d 5 rpc join -U pdcadm7 (4.2.10) (24.21 KB, text/plain)
2016-06-29 14:52 UTC, Heinrich Mislik
no flags Details
tcpdump of net -d 5 rpc join -U pdcadm7 (4.2.10) (40.72 KB, application/vnd.tcpdump.pcap)
2016-06-29 14:53 UTC, Heinrich Mislik
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heinrich Mislik 2016-06-29 14:48:49 UTC
Created attachment 12237 [details]
output of testparm -v (4.2.3)

After update from 4.2.3 to 4.2.10 on Centos 7, cannot join to NT4 Domain an Samba:

First try (success) was with:

# rpm -qa samba*
samba-libs-4.2.3-12.el7_2.x86_64
samba-winbind-clients-4.2.3-12.el7_2.x86_64
samba-common-libs-4.2.3-12.el7_2.x86_64
samba-winbind-modules-4.2.3-12.el7_2.x86_64
samba-winbind-4.2.3-12.el7_2.x86_64
samba-client-libs-4.2.3-12.el7_2.x86_64
samba-common-tools-4.2.3-12.el7_2.x86_64
samba-common-4.2.3-12.el7_2.noarch
samba-4.2.3-12.el7_2.x86_64

Second try (failure) with: 

#rpm -qa samba*
samba-common-libs-4.2.10-6.2.el7_2.x86_64
samba-common-4.2.10-6.2.el7_2.noarch
samba-4.2.10-6.2.el7_2.x86_64
samba-libs-4.2.10-6.2.el7_2.x86_64
samba-client-libs-4.2.10-6.2.el7_2.x86_64
samba-winbind-clients-4.2.10-6.2.el7_2.x86_64
samba-common-tools-4.2.10-6.2.el7_2.x86_64
samba-winbind-modules-4.2.10-6.2.el7_2.x86_64
samba-winbind-4.2.10-6.2.el7_2.x86_64

See attached Files!

See also:

http://lists-archives.com/samba/96690-winbind-trusted-domain-regression-after-upgrade-to-samba-4-2-10.html

Regards

Heinrich
Comment 1 Heinrich Mislik 2016-06-29 14:50:08 UTC
Created attachment 12238 [details]
output of net -d 5 rpc join -U pdcadm7 (4.2.3)
Comment 2 Heinrich Mislik 2016-06-29 14:51:01 UTC
Created attachment 12239 [details]
tcpdump of net -d 5 rpc join -U pdcadm7 (4.2.3)
Comment 3 Heinrich Mislik 2016-06-29 14:51:56 UTC
Created attachment 12240 [details]
output of testparm -v (4.2.10)
Comment 4 Heinrich Mislik 2016-06-29 14:52:39 UTC
Created attachment 12241 [details]
output of net -d 5 rpc join -U pdcadm7 (4.2.10)
Comment 5 Heinrich Mislik 2016-06-29 14:53:24 UTC
Created attachment 12242 [details]
tcpdump of net -d 5 rpc join -U pdcadm7 (4.2.10)
Comment 6 Stefan Metzmacher 2016-06-29 18:38:57 UTC
What kind of domain controller are you using?
Samba 3.5 or 3.6?

The problem is the same as bug #11982.

*** This bug has been marked as a duplicate of bug 11982 ***
Comment 7 Heinrich Mislik 2016-07-01 11:08:31 UTC
(In reply to Stefan Metzmacher from comment #6)

I must admit it's samba 3.4 an Centos 5. Does this mean, that upgrading the domain controller will solve this? I will do this upgrade anyway in the near future. 

Thanks for your help.

Cheers

Heinrich