Bug 1197 - "force group" directive group
"force group" directive group
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2a
All Linux
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-19 16:42 UTC by Guilherme Barile
Modified: 2005-11-14 09:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guilherme Barile 2004-03-19 16:42:42 UTC
When you have a share like
[share]
path = /var/something/%g
force group = +admin

And let´s suppose you have a user "user" with primary group "users" which 
doesn´t belong to group admin.
When this user accesses this share, it will put him in the 
directory /var/something/admin
He will be able to create files, and these files will belong to group "users", 
as expected.
The main problem is the %g on the path
Comment 1 Gerald (Jerry) Carter 2004-03-19 19:59:34 UTC
The way that you describe it, this would appear to be by design.
Are you saying that Samba 2.2 behaved differntly ? 

Also, please see the patch in BUG 417 and test that to see if to 
changes the bahvior.
Comment 2 Gerald (Jerry) Carter 2004-04-22 20:27:03 UTC
no response.  Closing.
Comment 3 Gerald (Jerry) Carter 2005-11-14 09:28:51 UTC
database cleanup