Bug 11950 - Failed to start service 'smb' - NT_STATUS_INVALID_SYSTEM_SERVICE
Failed to start service 'smb' - NT_STATUS_INVALID_SYSTEM_SERVICE
Status: RESOLVED INVALID
Product: Samba 4.1 and newer
Classification: Unclassified
Component: AD: LDB/DSDB/SAMDB
4.4.3
x64 Linux
: P5 normal
: ---
Assigned To: Andrew Bartlett
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-06 08:51 UTC by Rene
Modified: 2016-07-29 02:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rene 2016-06-06 08:51:18 UTC
[root@rene-manjaro-work ~]# cat /var/log/samba/log.samba 
[2016/06/06 10:46:10.517043,  0] ../source4/smbd/server.c:373(binary_smbd_main)
  samba version 4.4.3 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2016
[2016/06/06 10:46:10.517137,  3] ../source4/smbd/server.c:384(binary_smbd_main)
  Becoming a daemon.
[2016/06/06 10:46:10.519347,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'gssapi_spnego' registered
[2016/06/06 10:46:10.519399,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'gssapi_krb5' registered
[2016/06/06 10:46:10.519424,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'gssapi_krb5_sasl' registered
[2016/06/06 10:46:10.519438,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'spnego' registered
[2016/06/06 10:46:10.519452,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'schannel' registered
[2016/06/06 10:46:10.519466,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'naclrpc_as_system' registered
[2016/06/06 10:46:10.519481,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'sasl-EXTERNAL' registered
[2016/06/06 10:46:10.519494,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'ntlmssp' registered
[2016/06/06 10:46:10.519507,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'ntlmssp_resume_ccache' registered
[2016/06/06 10:46:10.519521,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'http_basic' registered
[2016/06/06 10:46:10.519536,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'http_ntlm' registered
[2016/06/06 10:46:10.519550,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'krb5' registered
[2016/06/06 10:46:10.519562,  3] ../auth/gensec/gensec_start.c:907(gensec_register)
  GENSEC backend 'fake_gssapi_krb5' registered
[2016/06/06 10:46:10.519585,  3] ../source4/ntptr/ntptr_base.c:67(ntptr_register)
  NTPTR backend 'simple_ldb'
[2016/06/06 10:46:10.519619,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'default' for type 1 registered
[2016/06/06 10:46:10.519634,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'posix' for type 1 registered
[2016/06/06 10:46:10.519648,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'unixuid' for type 1 registered
[2016/06/06 10:46:10.519660,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'unixuid' for type 3 registered
[2016/06/06 10:46:10.519673,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'unixuid' for type 2 registered
[2016/06/06 10:46:10.519686,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'cifs' for type 1 registered
[2016/06/06 10:46:10.519701,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'smb2' for type 1 registered
[2016/06/06 10:46:10.519715,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'simple' for type 1 registered
[2016/06/06 10:46:10.519728,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'cifsposix' for type 1 registered
[2016/06/06 10:46:10.519741,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'default' for type 3 registered
[2016/06/06 10:46:10.519757,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'default' for type 2 registered
[2016/06/06 10:46:10.519771,  3] ../source4/ntvfs/ntvfs_base.c:79(ntvfs_register)
  NTVFS backend 'nbench' for type 1 registered
[2016/06/06 10:46:10.520472,  3] ../source4/smbd/process_model.c:97(register_process_model)
  PROCESS_MODEL 'single' registered
[2016/06/06 10:46:10.520492,  3] ../source4/smbd/process_model.c:97(register_process_model)
  PROCESS_MODEL 'standard' registered
[2016/06/06 10:46:10.548570,  3] ../source4/auth/ntlm/auth.c:675(auth_register)
  AUTH backend 'sam' registered
[2016/06/06 10:46:10.548603,  3] ../source4/auth/ntlm/auth.c:675(auth_register)
  AUTH backend 'sam_ignoredomain' registered
[2016/06/06 10:46:10.548611,  3] ../source4/auth/ntlm/auth.c:675(auth_register)
  AUTH backend 'anonymous' registered
[2016/06/06 10:46:10.548628,  3] ../source4/auth/ntlm/auth.c:675(auth_register)
  AUTH backend 'winbind' registered
[2016/06/06 10:46:10.548635,  3] ../source4/auth/ntlm/auth.c:675(auth_register)
  AUTH backend 'winbind_wbclient' registered
[2016/06/06 10:46:10.548643,  3] ../source4/auth/ntlm/auth.c:675(auth_register)
  AUTH backend 'name_to_ntstatus' registered
[2016/06/06 10:46:10.548650,  3] ../source4/auth/ntlm/auth.c:675(auth_register)
  AUTH backend 'unix' registered
[2016/06/06 10:46:10.570613,  3] ../lib/ldb-samba/ldb_wrap.c:325(ldb_wrap_connect)
  ldb_wrap open of privilege.ldb
[2016/06/06 10:46:10.570830,  0] ../source4/smbd/server.c:485(binary_smbd_main)
  samba: using 'standard' process model
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
[2016/06/06 10:46:10.572332,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'rpcecho' registered
[2016/06/06 10:46:10.572370,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'epmapper' registered
[2016/06/06 10:46:10.572381,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'remote' registered
[2016/06/06 10:46:10.572454,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'srvsvc' registered
[2016/06/06 10:46:10.572463,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'wkssvc' registered
[2016/06/06 10:46:10.572470,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'unixinfo' registered
[2016/06/06 10:46:10.572486,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'samr' registered
[2016/06/06 10:46:10.572497,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'winreg' registered
[2016/06/06 10:46:10.572504,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'netlogon' registered
[2016/06/06 10:46:10.572511,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'dssetup' registered
[2016/06/06 10:46:10.572518,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'lsarpc' registered
[2016/06/06 10:46:10.572525,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'backupkey' registered
[2016/06/06 10:46:10.572532,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'spoolss' registered
[2016/06/06 10:46:10.572542,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'drsuapi' registered
[2016/06/06 10:46:10.572549,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'browser' registered
[2016/06/06 10:46:10.572561,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'eventlog6' registered
[2016/06/06 10:46:10.572568,  3] ../source4/rpc_server/dcerpc_server.c:1717(dcerpc_register_ep_server)
  DCERPC endpoint server 'dnsserver' registered
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
[2016/06/06 10:46:10.575718,  0] ../source4/smbd/service_task.c:35(task_server_terminate)
  task_server_terminate: [ldap_server: no LDAP server required in member server configuration]
[2016/06/06 10:46:10.575781,  2] ../source4/smbd/process_standard.c:375(standard_terminate)
  standard_terminate: reason[ldap_server: no LDAP server required in member server configuration]
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
[2016/06/06 10:46:10.576472,  0] ../source4/smbd/service_task.c:35(task_server_terminate)
  task_server_terminate: [cldap_server: no CLDAP server required in member server configuration]
[2016/06/06 10:46:10.576519,  2] ../source4/smbd/process_standard.c:375(standard_terminate)
  standard_terminate: reason[cldap_server: no CLDAP server required in member server configuration]
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
[2016/06/06 10:46:10.577132,  0] ../source4/smbd/service_task.c:35(task_server_terminate)
  task_server_terminate: [kdc: no KDC required in member server configuration]
[2016/06/06 10:46:10.577188,  2] ../source4/smbd/process_standard.c:375(standard_terminate)
  standard_terminate: reason[kdc: no KDC required in member server configuration]
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
[2016/06/06 10:46:10.578598,  0] ../source4/smbd/service_task.c:35(task_server_terminate)
  task_server_terminate: [dreplsrv: no DSDB replication required in domain member configuration]
[2016/06/06 10:46:10.578679,  2] ../source4/smbd/process_standard.c:375(standard_terminate)
  standard_terminate: reason[dreplsrv: no DSDB replication required in domain member configuration]
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
[2016/06/06 10:46:10.581691,  0] ../source4/smbd/service_task.c:35(task_server_terminate)
  task_server_terminate: [kccsrv: no KCC required in domain member configuration]
[2016/06/06 10:46:10.581761,  2] ../source4/smbd/process_standard.c:375(standard_terminate)
  standard_terminate: reason[kccsrv: no KCC required in domain member configuration]
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
[2016/06/06 10:46:10.582946,  0] ../source4/smbd/service.c:98(server_service_startup)
  Failed to start service 'smb' - NT_STATUS_INVALID_SYSTEM_SERVICE
[2016/06/06 10:46:10.583048,  0] ../lib/util/become_daemon.c:111(exit_daemon)
  STATUS=daemon failed to start: Samba failed to start services, error code -1073741796
samba: setproctitle not initialized, please either call setproctitle_init() or link against libbsd-ctor.
[2016/06/06 10:46:10.583378,  0] ../source4/smbd/service_task.c:35(task_server_terminate)
  task_server_terminate: [dns: no DNS required in member server configuration]
[2016/06/06 10:46:10.583433,  2] ../source4/smbd/process_standard.c:375(standard_terminate)
  standard_terminate: reason[dns: no DNS required in member server configuration]
[2016/06/06 10:46:10.587244,  0] ../source4/smbd/server.c:122(sig_term)
[2016/06/06 10:46:10.587244,  0] ../source4/smbd/server.c:122(sig_term)
  Exiting pid 7792 on SIGTERM
  Exiting pid 7796 on SIGTERM
[2016/06/06 10:46:10.587563,  0] ../source4/smbd/server.c:122(sig_term)
[2016/06/06 10:46:10.587578,  0] ../source4/smbd/server.c:122(sig_term)
  Exiting pid 7787 on SIGTERM
  Exiting pid 7783 on SIGTERM
[2016/06/06 10:46:10.587748,  0] ../source4/smbd/server.c:122(sig_term)
  Exiting pid 7784 on SIGTERM
[2016/06/06 10:46:10.588291,  0] ../source4/smbd/server.c:122(sig_term)
  Exiting pid 7785 on SIGTERM
[2016/06/06 10:46:10.588381,  0] ../source4/smbd/server.c:122(sig_term)
  Exiting pid 7794 on SIGTERM
[root@rene-manjaro-work ~]#
Comment 1 Andrew Bartlett 2016-06-06 08:59:17 UTC
The issue here is that you have specified 'smb' in 'server services', but have not built Samba with the ntvfs file server (no longer built by default). 

Change smb to s3fs and it should work fine, or replace the line with just the services you require to be added/disabled compared to the default, eg 

server services = -dns

Additionally, you seem to be running the 'samba' binary on a member server, which only makes sense in some very limited situations.

Perhaps re-post this back to the samba@ mailing list, this appears to be a support issue not a bug.

Thanks,
Comment 2 Rene 2016-06-06 09:52:01 UTC
Hello,

i want to add my manjaro installation into an existing domain, 
i followed the guid from the arch wiki,

and it doesnt mater what i change, i always end up with this error.

Greetz
Comment 3 Andrew Bartlett 2016-07-29 02:45:55 UTC
Per my last comment, this is not a support forum.

Sorry,