Bug 1187 - Winbind internal error 6
Winbind internal error 6
Status: RESOLVED DUPLICATE of bug 1127
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.2a
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-13 06:07 UTC by Ronald Moesbergen
Modified: 2005-11-14 09:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Moesbergen 2004-03-13 06:07:29 UTC
Hi,

I have a production system running samba 3.0.2a. I'm getting the following
errors once or twice a day:

this one is from the syslog:
ma-sv-user winbindd[3604]: [2004/03/08 11:25:37, 0] lib/fault.c:fault_report(36)
ma-sv-user winbindd[3604]:  
===============================================================
ma-sv-user winbindd[3604]: [2004/03/08 11:25:37, 0] lib/fault.c:fault_report(37)
ma-sv-user winbindd[3604]:   INTERNAL ERROR: Signal 6 in pid 3603 (3.0.2a)
ma-sv-user winbindd[3604]:   Please read the appendix Bugs of the Samba HOWTO
collection
ma-sv-user winbindd[3604]: [2004/03/08 11:25:37, 0] lib/fault.c:fault_report(39)
ma-sv-user winbindd[3604]:  
===============================================================
ma-sv-user winbindd[3604]: [2004/03/08 11:25:37, 0] lib/util.c:smb_panic(1400)
ma-sv-user winbindd[3604]:   PANIC: internal error
ma-sv-user winbindd[3604]: [2004/03/08 11:25:37, 0] lib/util.c:smb_panic(1408)
ma-sv-user winbindd[3604]:   BACKTRACE: 4 stack frames:
ma-sv-user winbindd[3604]:    #0 /usr/sbin/winbindd(smb_panic+0xed) [0x80bce30]
ma-sv-user winbindd[3604]:    #1 /lib/libc.so.6(abort+0x180) [0x4015e224]
ma-sv-user winbindd[3604]:    #2 /lib/libc.so.6 [0x401568e9]
ma-sv-user winbindd[3604]:    #3 /usr/lib/libldap.so.2(ldap_get_values+0x1f2)
[0x40112d0a]
ma-sv-user winbindd[3604]:

and one from log.winbind:
[2004/03/12 13:45:05, 1] libads/ads_ldap.c:ads_name_to_sid(64)
  name_to_sid: SG_Act not found
[2004/03/12 13:45:05, 1] nsswitch/winbindd_group.c:winbindd_getgrnam(283)
  group SG_Act in domain MASTER does not exist
[2004/03/12 13:45:28, 1] libads/ads_ldap.c:ads_name_to_sid(64)
  name_to_sid: SG_Act not found
[2004/03/12 13:45:28, 1] nsswitch/winbindd_group.c:winbindd_getgrnam(283)
  group SG_Act in domain MASTER does not exist
winbindd: getvalues.c:36: ldap_get_values: Assertion `entry != ((void *)0)' failed.
[2004/03/12 13:45:45, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2004/03/12 13:45:45, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 6 in pid 25025 (3.0.2a)
  Please read the appendix Bugs of the Samba HOWTO collection
[2004/03/12 13:45:45, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2004/03/12 13:45:45, 0] lib/util.c:smb_panic(1400)
  PANIC: internal error
[2004/03/12 13:45:45, 0] lib/util.c:smb_panic(1408)
  BACKTRACE: 4 stack frames:
   #0 /usr/sbin/winbindd(smb_panic+0xed) [0x80bce30]
   #1 /lib/libc.so.6(abort+0x180) [0x4015e224]
   #2 /lib/libc.so.6 [0x401568e9]
   #3 /usr/lib/libldap.so.2(ldap_get_values+0x1f2) [0x40112d0a]

The server runs with security = ADS, joined in a windows 2000 active directory.
ldap version is openldap 2.1.26, kerberos mit-krb5 1.2.7. Unfortunately I
couln't find a core file anywhere. If more info is needed, please email me.

Thanks,
Ronald.
Comment 1 Gerald (Jerry) Carter 2004-03-15 08:33:52 UTC

*** This bug has been marked as a duplicate of 1127 ***
Comment 2 Gerald (Jerry) Carter 2005-11-14 09:26:49 UTC
database cleanup