Bug 1177 - Saving files to Samba shares with "profile acls = yes" using MS Office XP/2003 sets the read-only flag on the files
Saving files to Samba shares with "profile acls = yes" using MS Office XP/200...
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.2a
All Windows XP
: P3 major
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 07:11 UTC by Jonas Olsson
Modified: 2005-08-24 10:19 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Olsson 2004-03-11 07:11:42 UTC
This is a bug report based on the following post to the samba mailing list:

http://lists.samba.org/archive/samba/2004-March/081690.html

I am experiencing similar problems when saving files with Word and Excel from
Office XP and Office 2003 on shares with the "profile acls = yes" directive set.

In the case of Excel the .xls file is initially created with write permitted for
the user but when a change is made to the file and Excel saves it again the
write flag for the user is removed. The Unix mode changes from 0644 to 0444. The
attempt to save the changes is met with the following error message from Excel:

"The document was saved successfully, but Excel cannot re-open it because of a
sharing violation. Please close the document and try to open it again."

In the case of Word the .doc file is initially created without the write flag
for the user, Unix mode 0444. Attempts to save changes to the file are met with
a file selection dialogue prompting for a writable file.

Relevant sections of my smb.conf are:

----------------------
[global]
create mask = 0755
directory mask = 0755

[homes]
        comment         = Home directory
        browseable      = no
        writeable       = yes
        csc policy      = disable
        profile acls    = yes


No changes to lock settings have been made. Setting "nt acl support" or "profile
acls" to "no" for the share in question fixes the problem.

Operating system: Fedora Core 1 on x86 (Intel).
Filesystem: ext3fs (no ACL support in the filesystem activated)

Is this an expected side effect of setting "profile acls = yes" on a share?
Comment 1 Gerald (Jerry) Carter 2004-03-17 10:21:45 UTC
reproduced using office 2002, 2ksp4 client 
and latest Samba 3.0 cvs code.
Comment 2 Jeremy Allison 2004-03-19 18:33:55 UTC
Just a data point - I can't reproduce this with Win2k SP4 (build 2195) and Excel
2000 (9.0.3821 SR1) release.

Jeremy.
Comment 3 Gerald (Jerry) Carter 2005-02-11 07:43:11 UTC
please retest against 3.0.11 and let us know if the bug still exists.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:19:59 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.